More in this section

Forums / General Discussions / Accessing PageService.svc ends with a 302 Object Moved

Accessing PageService.svc ends with a 302 Object Moved

4 posts, 0 answered
  1. Bruno
    Bruno avatar
    3 posts
    Registered:
    03 May 2008
    22 Feb 2011
    Link to this post
    Have uploaded a site to a host provider.
    The front end seems to work ok.

    However when trying to access either the Pages or Page Templates, a message would popup saying Resource cannot be found.

    I looked at fiddler and it shows that it tries to access the PageServiec.svc it gets a 302 response and to access /login.aspx instead. This the returns a 404 response.

    I have uploaded the files again in case there was a problem with the upload but I am still getting the same issue.

    Is there anything you can suggest?


    Thanks Damian
  2. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    22 Feb 2011
    Link to this post
    Hi Bruno,

    The front-end part is also using the same web service, but you've said there are no issues there. Is it possible this to be related to the permissions? Do you have any special permissions applied to the pages section? I can guess there is a problem there, because you are being redirected to the login page.

    Greetings,
    Georgi
    the Telerik team
  3. Bruno
    Bruno avatar
    3 posts
    Registered:
    03 May 2008
    23 Feb 2011
    Link to this post
    But on the development machine, there is no issue with the permissions.
    And it is getting the 404 error for the login page.

    Fiddler shows this:
    # Result Protocol URL Body Caching Content-Type Process Comments Custom
    18 302 HTTP /Sitefinity/Services/Pages/PagesService.svc/?managerType=Telerik.Sitefinity.Modules.Pages.PageManager&providerName=&itemType=Telerik.Sitefinity.Pages.Model.PageNode&hierarchyMode=true&sortExpression=Title%20ASC%20HTTP/1.1 593 private application/json; charset=utf-8 iexplore:9940
    19 404 HTTP /login.aspx?ReturnUrl=%2fSitefinity%2fServices%2fPages%2fPagesService.svc%2f%3fmanagerType%3dTelerik.Sitefinity.Modules.Pages.PageManager%26providerName%3d%26itemType%3dTelerik.Sitefinity.Pages.Model.PageNode%26hierarchyMode%3dtrue%26sortExpression%3dTitle%2520ASC%2520HTTP%2f1.1&managerType=Telerik.Sitefinity.Modules.Pages.PageManager&providerName=&itemType=Telerik.Sitefinity.Pages.Model.PageNode&hierarchyMode=true&sortExpression=Title%20ASC%20HTTP/1.1 3,451 private text/html; charset=utf-8 iexplore:9940

  4. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    01 Mar 2011
    Link to this post
    Hello Bruno,

    It looks like your website is set to run under .NET Medium Trust. Can you please verify that? If this is the case you should set the website to run in Full Trust as we do not support Medium Trust.

    Kind regards,
    Radoslav Georgiev
    the Telerik team
4 posts, 0 answered