More in this section
Forums / General Discussions / Applying custom styles to RadEditor - Sitefinity v7.1

Applying custom styles to RadEditor - Sitefinity v7.1

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
3 posts, 0 answered
  1. Richard
    Richard avatar
    63 posts
    Registered:
    20 Jan 2010
    18 Sep 2014
    Link to this post

    Hi,

    I'm trying to add some custom styles to the RadEditor by adding my custom stylesheet via Settings > Advanced > Appearance > Rad Editors content area CSS file > path to stylesheet. 

    When I go into the RadEditor I can see that my stylesheet has loaded using the Developer Tools in Chrome yet they do not appear in the styles dropdown. I have restart IIS and rebuilt my solution yet they are still missing. 

    Am I missing something or is there an easier way to add custom styles for users to be able to add to the content blocks?

    Thanks

    Richard

  2. Bilyana
    Bilyana avatar
    1 posts
    Registered:
    21 May 2013
    19 Sep 2014 in reply to Richard
    Link to this post

    Hello Richard,

     You can navigate to Administration->Settings->Global Settings->Text editor, where you can edit the default tool set. Under the <root> node you can add a cssFiles section, which contains the links to the stylesheets you want to use.

    <cssFiles>
        <item name="~/css/sitestylesheet.css" />
    </cssFiles>
    ...
    </root>

    This would load all css classes from the stylesheet in the RadEditor. If want to explicitly list the classes you want listed you can add the <classes> section as well:

    <classes>
        <class name="Red Text" value=".redText" />
    </classes>
    ...
    </root>

    Bilyana

  3. Richard
    Richard avatar
    63 posts
    Registered:
    20 Jan 2010
    19 Sep 2014
    Link to this post

    Thanks Bilyana - all working.

3 posts, 0 answered