More in this section
Forums / General Discussions / Azure search service 502 error

Azure search service 502 error

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
1 posts, 0 answered
  1. Jason
    Jason avatar
    2 posts
    19 Aug 2015
    11 Jan 2016
    Link to this post

    I have a 8.2 sitefinity multisite project. I'm hosting it in an azure web app.  It seems to be working except trying to reindex a search service. 


    I developed locally using Lucene which worked fine.  After deploying to azure, I changed the search service to Azure per the documentation, and entered the URL and API key.  Then I try to reindex and receive a 502 bad gateway error.  I did change the CORS settings in the search service to allow ALL as well. 


    I wasn't sure if I had to create an index in azure first or not, so I tried both ways and received the same error.  Has anyone successfully hooked up the azure search service and if so, what were the configuration steps?  I feel like the documentation might be missing something.

1 posts, 0 answered