More in this section

Forums / General Discussions / Blog Selector (based on SimpleImageSelector) trouble

Blog Selector (based on SimpleImageSelector) trouble

2 posts, 0 answered
  1. Chris
    Chris avatar
    2 posts
    Registered:
    31 Mar 2011
    04 Aug 2011
    Link to this post
    I hope to get some help modifying the recently posted example of the SimpleImagesSelector custom field to instead be a BlogPostSelector.  What I'm trying to do is to create a Blog for Locations and another Blog for JobPostings.  When I create a JobPosting I want to associate that JobPosting to a Location, so that other code can display all of the JobPostings that are at a Location.

    I'm having fundamental problems getting the SimpleImageSelector code working within my namespace, with my fieldtypes (I obviously don't need images), while applying minimal changes to the sample code.  And now I'm stuck.

    The error that I'm currently recieving tells me that that the javascript files I'm trying to include can't be included.  But I have a hunch that this is not the true reason for my error.  Instead I think a piece of code is erroring before the javascript can be injected and the errors I'm seeing are simply a symptom. 

    I'm not sure where to start with providing information that will fix this issue.  So, here's the error my debugger found:

    1. on
    public override IEnumerable<ScriptDescriptorGetScriptDescriptors()
    

    I can inspect that the asp:Label control I added is null, while other controls have values.  Nothing I do seems to alter this.

    2. after I step through the parts of that C# code I get this error:

    No Source Available 

    Call stack location:
    App_Web_telerik.sitefinity.resources.templates.backend.contentui.detailview.ascx.f785aa1a.tetfqd2n.dll!
    ASP.sfres_telerik_sitefinity_resources_templates_backend_contentui_detailview_ascx.__Render__control1(System.
    Web.UI.Control parameterContainer) Line 141

    This leads me to ask: How could my code possibly not be including the proper telerik code?  I have all the proper dlls as references?
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    09 Aug 2011
    Link to this post
    Hi Chris,

    Do you detect any JS errors on your page? Is it possible that you have not set the script files to be built as embedded resources?

    Greetings,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered