More in this section

Forums / General Discussions / Broken content item URLs since Sitefinity 5 upgrade: solution

Broken content item URLs since Sitefinity 5 upgrade: solution

1 posts, 0 answered
  1. Thomas
    Thomas avatar
    223 posts
    19 Jan 2011
    03 May 2012
    Link to this post

    Just a quick post to share what I found, in case it may help anyone. Apologies if this has already been reported elsewhere.

    Since I upgraded from SF 4.3 to 5.0, some things that used to work no longer worked. It seems that in SF 5.0, there have been several important changes to the way URLs are handled.

    Example: enter a content block, and insert an image. Since the SF5 upgrade, the newly-inserted image was not displayed, because its URL was wrong. But if you saved the content block, then reopened it, the image worked (URL got fixed magically). About the URL, the first time around, rather than being "/my-lib/my-image.png", it was something like "http://http/my-lib/my-image.png". So URLs that used to be relative are now absolute, but the generated absolute URLs are wrong.

    This happened because I defined a value for the following setting: System / Site URL settings / The Host (used to be called "Site URL" in 4.3).

    The value I defined was "http://sitename.domainname"
    But since SF5, this causes issues. It no longer expects the protocol to be added in front of the site URL. So I changed it to just "sitename.domainname", and now everything works as it used to. Took me half a day to figure this out, so I thought I'd share.
1 posts, 0 answered