More in this section

Forums / General Discussions / Cannot access App_Data folder for theme

Cannot access App_Data folder for theme

3 posts, 0 answered
  1. Al
    Al avatar
    4 posts
    Registered:
    15 Jun 2011
    06 Jul 2011
    Link to this post
    I have Sitefinity running locally and am using the built in web server with VS 2010. Everything appears to work fine. So, I broke open teh documentation on adding a custom master page and theme. To begin, I used a simple Web application to test my master page and the styling (looks great). I then take that master page and theme and place it into the folder structure outlined in the documentation. Register both teh Page Template and the Theme, again according to teh documentation. I then proceed to create a page based on the newly added Page Template. The page loads, and no styles appear. I inspect the elements and find that the Uri for the CSS is fine, but I get a 403 error. I then realize that the folder is protected by default so you cannot publically browse it. So, I tried adding Network Service with Full permissions and its the same. Now I am confused. I am running VS2010 with administrator privledges and again using the built in web server. Please tell me there is something simple I can do to fix this. Thanks much.
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    06 Jul 2011
    Link to this post
    Hi Al,

    Do you add your stylesheets in Global folder? If they are inside it, the application should load them automatically on the page without issue. After you granted the account that runs your application pool with read rights over the theme/template folders do you get issues?

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Al
    Al avatar
    4 posts
    Registered:
    15 Jun 2011
    10 Jul 2011
    Link to this post
    I was able to move the CSS file to the Global folder and it worked. Now for as to why it will not work in the CSS folder where it 'should' reside according to the documentation. Again, I am running the project under VS 2010 which is running with Administrator privileges. Accessing the file system should not be a problem. Once the project is move to a server, its given its own security context and application pool, etc. Some advise/help would be great. Maybe a KB article that specifically addresses using Sitefinity with IIS, IIS Express and VS Web Server (Casini). Thanks.
3 posts, 0 answered