More in this section

Forums / General Discussions / Classification

Classification

6 posts, 0 answered
  1. Rafael
    Rafael avatar
    19 posts
    Registered:
    29 Jul 2011
    11 Aug 2011
    Link to this post
    My question is so easy but i cannot fix the problem.

    I just create a Classification and i want add all the pages that i have in my site into this classification, it's possible?

    Regards.

    Rafael Monaco
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    12 Aug 2011
    Link to this post
    Hello Rafael,

    It is possible only programmatically.

    App.WorkWith().DynamicData().Type(typeof(PageData)).Field().TryCreateNew("mycustomfield", null).SaveChanges();

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Rafael
    Rafael avatar
    19 posts
    Registered:
    29 Jul 2011
    12 Aug 2011
    Link to this post
    Ok, i try with that and then tell you!
    Now i have other problem, whent i create a list, and list item i go to set the custom field, and go into
    Defualt Item>Status>Appereance
    And choose the option "All screens where you work with list items in the Backend", then when i try to save the change show me an error, i attach the error.

    Thanks and regards.

    Ing. Rafael Monaco
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    12 Aug 2011
    Link to this post
    Hello Rafael,

    Enable service tracer tool and check the error from it. Something has gone wrong with the data - most probably with the database.

    http://msdn.microsoft.com/en-us/library/ms732023.aspx

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Rafael
    Rafael avatar
    19 posts
    Registered:
    29 Jul 2011
    12 Aug 2011
    Link to this post
    I have a lot of Default items,  and 3 or 4 its types are UNKNOWN, i think that is the problem, because when i try to set those field show up the same error!

    I attach to you can see!

    Regards

  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    17 Aug 2011
    Link to this post
    Hi Rafael,

    This is not the problem, please check the service log. By default the type of the fields you are showing is "Unknown". You can check this using a new installation of Sitefinity 4.2.

    There is some issue with ModuleEditor Service that is used when you click on custom field section. The service gets all fields - default and custom one and bind them to the  FieldsGrid control you see.

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
6 posts, 0 answered