More in this section

Forums / General Discussions / Control Designer Layout issues if a RadRotator is present on the page

Control Designer Layout issues if a RadRotator is present on the page

6 posts, 1 answered
  1. Daniel
    Daniel avatar
    35 posts
    Registered:
    15 Jun 2010
    30 Aug 2010
    Link to this post
    Hello there,

    I've just detected a small graphical issue while using the RadRotator control from the RadControls toobox (or if it's present on a Custom Widget or User Control).

    This issue only seems to be happening on Internet Explorer (tried with the latest version), on Chrome and Firefox it works as it should.

    The steps to reproduce are the following:

    1. Edit a page
    2. Add a Rotator from the RadControl Toolbox or a Custom Control which has a RadRotator on it the anywhere on the page
    3. Edit any control on the page (The Designer layout will appear correctly)
    4. Publish the page
    5. Edit the page once again
    6. Edit any control on the page (The Designer layout will appear strange, with an icon on the top left and without the white border)

    Is there any way to solve this quickly?

    Thanks in advance!
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    01 Sep 2010
    Link to this post
    Hi Daniel,

    Thank you for using our services.

    I have tried reproducing this issue with the mentioned browser. You can see a short video of what steps I have been taking to reproduce the issue. I have not been able to reproduce the issue so far. Please take a look at the screen cast and tell me if I am not taking any steps that I should take. Also this might be caused by styles existing on your page. Can you let us know if you have any custom styles.

    All the best,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Daniel
    Daniel avatar
    35 posts
    Registered:
    15 Jun 2010
    01 Sep 2010
    Link to this post
    Hello Radoslav and thank you for your answer,

    I tried setting up a new Sitefinity project and it in fact worked correctly, so I've decided to do a more throughout digging of what could be the issue and found out the following:

    I have some Custom Controls which have a FormDecorator on them, in order to decorate the controls they carry, I thought the FormDecorator would only apply itself on the controls present on the containing .ascx, but I've now found it's page wide. As such whenever I added a Custom Control which had a FormDecorator to a page, the decorator would also decorate the popups (Windows) causing them to appear like I've said.

    It's strange, though, that this only happened on Internet Explorer, on both Chrome and Firefox the designer Windows appeared correctly with any Custom Control which had a FormDecorator on the page.

    Thanks for the support!
  4. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    01 Sep 2010
    Link to this post
    Hi Daniel,

    Thank you for the clarification.

    The default behavior is that the form decorator styles the whole page unless specified to style a particular zone. You can also narrow down what types of controls to decorate by enumerating them in the DecoratedControls property.

    Regards,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Daniel
    Daniel avatar
    35 posts
    Registered:
    15 Jun 2010
    01 Sep 2010
    Link to this post
    Hello again,

    It seems the problem still persists.

    These are the steps to reproduce:

    1. Create a new page without using a Template (start from scratch), so that there any no external css files applied
    2. Add a RadCalendar control to the page
    3. Try the editor, it appears correctly
    4. Publish & ReOpen the page
    5. Add a Rotator to the page
    6. Try the editors, they appear correctly
    7. Publish & ReOpen the page
    8. Try the editors, they appear correctly
    9. Add a Combo Box
    10. Try the editors, they appear correctly, but the combo box ain't styled yet
    11. Publish & ReOpen the page
    12. The combo box now appears styled
    13. Try the editors, they will appear incorrectly

    I've tried this with 3 custom controls, two of them have only ASP HyperLink controls, differently styled through CSS files, the designers appear correctly. Then added a Rotator to the page, published and reopened and they now appear incorrectly. However, the designers appear correctly on both Firefox & Chrome.

    I've attached a Jing movie showing the steps I took and how they appear here. I didn't really knew how to configure Jing so the browser bars ain't showing. The movie starts with Internet explorer in order to show the error and then I switch to both Firefox and Chrome showing the designers appear correctly there. 

    PS: It seems I can't attach the Jing movie due to size limits, so I've uploaded it to our web server and it's located at http://ciberbit.dyndns.org/DesignerLayoutBug.swf .

    Please let me know if you can reproduce the error.

    Thanks in advance!
  6. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    03 Sep 2010
    Link to this post
    Hello Daniel,

    Thank you for the detailed guidance on how to reproduce the issue.

    We will log this for fixing and try to resolve this for next releases of the CMS.

    Best wishes,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
6 posts, 1 answered