More in this section

Forums / General Discussions / CSS in page versus editor

CSS in page versus editor

11 posts, 0 answered
  1. kz
    kz avatar
    21 posts
    Registered:
    10 Jul 2009
    04 Oct 2010
    Link to this post
    Might be a dumb question but I can't seem to get the css on the page to match what's in the editor.

    Say I go to a page and enter some generic content. I change the something to a h1 tag. Looks good and then update the content. I view the page and the text doesn't change. I even tried using a blank template with to make sure there was no issues with my on styles. If I change something like color or font size its fine? How does the page get it's css?

  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    04 Oct 2010
    Link to this post
    Hello kz,

    Thank you for using our services.

    The Editor uses a CSS file which defines how its content area looks like. The path to this file is ~/Sitefinity/Admin/Themes/Default/AjaxControlsSkins/Sitefinity/EditorContentArea.css. You have to transfer your theme styles to this file so that the editor content area looks in this way.

    Regards,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. SolarX
    SolarX avatar
    14 posts
    Registered:
    24 Oct 2006
    21 Oct 2010
    Link to this post
    Hi,

    I can't find this path in my 4.0 Beta 2 installation..?
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    21 Oct 2010
    Link to this post
    Hi SolarX,

    In Sitefinity 4.0 we use embedded resources and the ContentBlock  control that wraps RadEditor control works with EmbeddedResourcePropertySetter control. Currently we do not expose external templates for ContentBlock and HmlField control where we have declared the RadEdtior and it is not possible to set EditorContentArea.

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Bill
    Bill avatar
    6 posts
    Registered:
    17 Mar 2009
    16 Nov 2010
    Link to this post
    Hi,
    I seem to be having a similar problem. I think That I simply do not have the path to the CSS right, but I have not been able to figure out what the right pat is.
    I downloaded a new template and create a master page from the HTML. I got that to load Ok into Templates. I then copied the CSS to what I thought was the right directory, loaded it into the project, but it will not apply. This is where I have the files.

    Master Pages are in...
    C:\Documents and Settings\Administrator\My Documents\My Documents\WebSItes\CorporateClean\App_Data\Sitefinity\WebsiteTemplates\DefaultTemplate\App_Master

    And the CSS is in
    C:\Documents and Settings\Administrator\My Documents\My Documents\WebSItes\CorporateClean\App_Data\Sitefinity\WebsiteTemplates\DefaultTemplate\App_Themes\DefaultTheme\Global
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    16 Nov 2010
    Link to this post
    Hi Bill,

    Could you register your template through Page Templates and the theme from Settings >> Appearance >> Frontend Themes

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Bill
    Bill avatar
    6 posts
    Registered:
    17 Mar 2009
    16 Nov 2010
    Link to this post
    Hi,
    Yes...I went into Administration/Appearance/Frontend Themes and created a new theme called CleanCorp with a path of ~\App_Data\Sitefinity\WebsiteTemplates\DefaultTemplate\App_Themes\DefaultTheme I left Namespace and AssemblyInfo blank.
  8. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    16 Nov 2010
    Link to this post
    Hello Bill,

    If the path to the theme is correct you should see it in the drop down. Also you have to use slashes, not back slashes. You can take a look at our Designers guide and SDK with samples.

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  9. Bill
    Bill avatar
    6 posts
    Registered:
    17 Mar 2009
    16 Nov 2010
    Link to this post
    Thanks,
    the slashes did it
  10. Bill
    Bill avatar
    6 posts
    Registered:
    17 Mar 2009
    16 Nov 2010
    Link to this post
    One last thing, Inside Default theme are three folders, Global, Images and Style. From the Design Doc it seems that all images for the CSS should be in the Images folder. They are not showing up. But that could be something in My Master file.
  11. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    16 Nov 2010
    Link to this post
    Hi Bill,

    If you are referencing the images relatively to the images folder they should show up. Most probably the path is not correct. You can easily observe this with FireBug tool.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
11 posts, 0 answered