More in this section

Forums / General Discussions / Custom Membership Provider

Custom Membership Provider

4 posts, 0 answered
  1. Eugene Lee
    Eugene Lee avatar
    2 posts
    Registered:
    05 Mar 2010
    03 Nov 2011
    Link to this post
    Hi,

    I have implemented a custom membership and role provider which inherits from MembershipDataProvider and RoleDataProvider.  I am using Sitefinity v4.2
    I am able to login to Sitefinity and see all the users and roles from my custom providers.  However, I was not able to access the Sitefinity backend pages when I tried to login using the custom membership provider.  I then proceeded to assign one of the roles to which the user belong to as an AdministrativeRole in Sitefinity via Administration --> Settings --> Security --> AdministrativeRoles.
    I was then able to login to the backend Sitefinity pages using a user from my custom membership provider.  However, later when I clicked on one of the Roles link, I was suddenly thrown out and adviced that someone is already using this username and password from another computer.  You need to log him/her off.  When I click to log the other user off and enter, I get thrown back to the login page again saying that I have been logged out from another computer.  Repeated attempts to login again comes back with the same messages i.e. someone else is already logged in, please log them off and then I get thrown back to the login page.  So right now I cant login using that user from my custom provider.

    I have reset the app pool, restarted the website and also cleared my browser cache/cookies.  However it is not working for me.  Is there a setting/property I need to set on login/logoff in my custom providers?

    Thanks.
  2. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    07 Nov 2011
    Link to this post
    Hello Eugene Lee,

    Well, the records for the currently logged in users are stored in the sf_lic_user_activity table. You can delete the record for this user and try again.

    Greetings,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Eugene Lee
    Eugene Lee avatar
    2 posts
    Registered:
    05 Mar 2010
    08 Nov 2011
    Link to this post
    Hi Lubomir,

    Thanks for the reply.  I find that if I do that, I can login again, but there seems to be a timeout expiry issue.  After about a minute or so, when I click on a link, I find that the page shows as timeout and I will be navigated to the login page again.  Then I will have that first error I described, where I am unable to login again until I set the IsLoggedIn to 0 in the database table.  Is there something that I might be doing incorrectly?  Would be happy to post code as well if it helps.
    Thanks.
    Eugene
  4. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    08 Nov 2011
    Link to this post
    Hello Eugene Lee,

    This looks like an issue with the code of your custom provider. Basically for each membership providers there are some parameters like applicationName, etc. applicationName is actually importand and you should add it. Also in Administration -> Settings -> Advanced -> Security there are some settings like BackendUsersSessionTimeoutDescription - please check what are their values.

    Kind regards,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
4 posts, 0 answered