More in this section
Forums / General Discussions / Disable Comments Module Expand/Collapse

Disable Comments Module Expand/Collapse

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
2 posts, 0 answered
  1. Chris
    Chris avatar
    1 posts
    22 Oct 2014
    07 Feb 2016
    Link to this post

    Hi all,

    I would like to disable the comments functionality to "expand" and "collapse" the comment. I can see that the js for the comments come from the Frontend.dll, and since it is a self invoking function, I cannot override it, as all its variables are local. If it is in the dll, I assumed that these things can be switched on/off from the Advanced Settings in the Comments section, but either I cannot find it, or it doesn't exist.

    Bottom line, where can I disable that thing. I don't want to overwrite it from the css, cause it is not a good practice, plus, I need to add a few more stuff in the comment, like user role and a report functionality.


    -- Sitefinity 8.2
    -- Feather 1.4

    Any help will be appreciated.



  2. Sabrie Nedzhip
    Sabrie Nedzhip avatar
    534 posts
    17 Aug 2017
    10 Feb 2016
    Link to this post
    Hi Chris,

    As far as I can see from the screenshot, you are using the Feather Comments widget on a page to display the comments. If so, please note that the widget has a property CommentTextMaxLength which defines the maximum length of the comment abstract that is displayed in the comments list.

    If the length of the comment exceeds the maximum length set in the CommentTextMaxLength field, the Read full comment link will be displayed for this comment in order to be able to display the whole content of the comment.

    So what I can suggest is that you open the Comments widget advanced settings and then click on Model button and find the CommentTextMaxLength field. Then please set a high value in this field and save the changes. This way you will make sure that always the full content of the comment is displayed in the comments list.

    Sabrie Nedzhip
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
2 posts, 0 answered