More in this section

Forums / General Discussions / document and files - can't preview images

document and files - can't preview images

5 posts, 0 answered
  1. Rabindra
    Rabindra avatar
    106 posts
    Registered:
    17 May 2009
    13 Mar 2012
    Link to this post
    Hi,
    I have made filesystem as default and all setting of filesystem remains the same. I created a library called "MSC images" and uploaded one image. Now how can I preview this image?
    When I got to Edit propertise of images, I see a button called "open the file". If I click on it, the url takes me to http://domainname/docs/msc-images/koala.jpg?Status=Temp&sfvrsn=4 and get 404 error.
    Looking at the link, I see a folder called docs which I don't have. If I browse to the folder, I see a file named "d44059b0-e779-4d9b-8f48-535017cb404f" created in App_Data\Storage\FileSystem\

    How can I preview images?

    regards,

  2. Jen Peleva
    Jen Peleva avatar
    568 posts
    Registered:
    10 Nov 2016
    15 Mar 2012
    Link to this post
    Hi Rabindra,

    Thank you for contacting Telerik Support.

    You can't find a docs folder in your project, because docs is actually a root url (part of the url, not a physycal folder). However, the default root url for image libraries is images. You can verify this by going to Administration -> Settings -> Libraries -> Images (take a look at the attached screenshot for further reference). Have you made modifications to the Root url property? Usually, you are able to change its name and then the urls of your images will be generated with the custom root url in them. Is it possible that you have published the image and then changed the value of this property? In this case the url of the image would have been generated already with the old value of the root url, but the images would be located under the new root url, so when the old url is requested you would get a 404 Not found error, simply because images aren't there anymore. However, every time you publish an item the  manager.RecompileItemUrls() method  is called and the url for the item is generated again. This means that even if somehow your url is constructed improperly, if you publish the image again, the correct, updated url should be constructed. Please try that and let us know if the issue persists.

    Kind regards,
    Jen Peleva
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    15 Mar 2012
    Link to this post
    Daer Rabindra
    Are you using a Small Business Edtion?
    Markus
  4. Rabindra
    Rabindra avatar
    106 posts
    Registered:
    17 May 2009
    16 Mar 2012
    Link to this post
    Hi Jen,
    No, I haven't changed anything. This is a clean install on my Windows 7 machine.
    All I did was created a filesystem library and uploaded a picture.

    @Markus: I am using Professional edition.

    regards,
  5. Jen Peleva
    Jen Peleva avatar
    568 posts
    Registered:
    10 Nov 2016
    20 Mar 2012
    Link to this post
    Hello Rabindra,

    Did you try the proposed solution - to republish the item? Also, does this happen with this image only or with all images and is it repoducible on other projects?

    Kind Regards,
    Jen Peleva
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
5 posts, 0 answered