More in this section

Forums / General Discussions / Error With IIS7 and Sitefinity Configuration

Error With IIS7 and Sitefinity Configuration

13 posts, 0 answered
  1. Dave
    Dave avatar
    8 posts
    Registered:
    10 Jun 2008
    01 Sep 2010
    Link to this post
    I am trying to setup the Sitefinity 4.0 Beta on Windows & with IIS 7.5 .  I am able to get to the point of successfully logging in to the admistrative side but as soon as I click on any of the options such as Pages or Users I get a "The resource could not be found" error (see attached error.jpg).  I have it running in Integrated Mode because classic mode would not allow me to get to the /sitefinity directory, I just got redirected back to the login.aspx page.  Below is my web.config file.  Any guesses as to what I am doing wrong?  This is preventing me from evaluating it any further and I cannot seem to find any help whatsoever on this issue.  Your help is highly Appreciated


    <?xml version="1.0" encoding="UTF-8"?>
    <!--
        Note: As an alternative to hand editing this file you can use the
        web admin tool to configure settings for your application. Use
        the Website->Asp.Net Configuration option in Visual Studio.
        A full list of settings and comments can be found in
        machine.config.comments usually located in
        \Windows\Microsoft.Net\Framework\v2.x\Config
    -->
    <configuration>
      <configSections>
        <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
          <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
            <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
            <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
              <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="Everywhere" />
              <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
              <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
              <section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
            </sectionGroup>
          </sectionGroup>
        </sectionGroup>
      </configSections>
      <appSettings />
      <!-- Set your mail settings here -->
      <!--<system.net>
          <mailSettings>
              <smtp from=""
                  <network host="" userName="" password="" port="" />
              </smtp>
          </mailSettings>
      </system.net>-->
      <!--<system.diagnostics>
        <trace autoflush="true" />
        <sources>
          <source name="System.ServiceModel"
                  switchValue="Information, ActivityTracing"
                  propagateActivity="true">
            <listeners>
              <add name="sdt"
                  type="System.Diagnostics.XmlWriterTraceListener"
                  initializeData= "SdrConfigExample.e2e" />
            </listeners>
          </source>
        </sources>
      </system.diagnostics>-->
      <system.web>
        <siteMap defaultProvider="SitefinitySiteMap">
          <providers>
            <add name="SitefinitySiteMap" type="Telerik.Sitefinity.Web.SitefinitySiteMap, Telerik.Sitefinity" taxonomyProvider="OpenAccessDataProvider" pageTaxonomy="Pages" rootNode="FrontendSiteMap" pageProvider="OpenAccessDataProvider" />
          </providers>
        </siteMap>
        <membership defaultProvider="Default">
          <providers>
            <clear />
            <!--<add name="FrontendUsers" type="Telerik.Sitefinity.Security.Data.SitefinityMembershipProvider, Telerik.Sitefinity"/>-->
            <add name="Default" type="Telerik.Sitefinity.Security.Data.SitefinityMembershipProvider, Telerik.Sitefinity" />
          </providers>
        </membership>
        <globalization uiCulture="auto" culture="auto" resourceProviderFactoryType="Telerik.Sitefinity.Localization.ExtendedResourceProviderFactory, Telerik.Sitefinity" />
        <!--
                Set compilation debug="true" to insert debugging
                symbols into the compiled page. Because this
                affects performance, set this value to true only
                during development.
            -->
        <compilation debug="true">
          <assemblies>
            <add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
            <add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
            <add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
            <add assembly="System.Web.Routing, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
            <add assembly="System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
          </assemblies>
          <buildProviders>
            <remove extension=".svc" />
            <add extension=".svc" type="System.ServiceModel.Activation.ServiceBuildProvider, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
          </buildProviders>
        </compilation>
        <!--
                The <authentication> section enables configuration
                of the security authentication mode used by
                ASP.NET to identify an incoming user.
            -->
        <authentication mode="Forms" />
        <customErrors mode="Off"></customErrors>
        <!--
                The <customErrors> section enables configuration
                of what to do if/when an unhandled error occurs
                during the execution of a request. Specifically,
                it enables developers to configure html error pages
                to be displayed in place of a error stack trace.
     
            <customErrors mode="RemoteOnly" defaultRedirect="GenericErrorPage.htm">
                <error statusCode="403" redirect="NoAccess.htm" />
                <error statusCode="404" redirect="FileNotFound.htm" />
            </customErrors>
            -->
        <pages>
          <controls>
            <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
            <add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
            <add tagPrefix="telerik" namespace="Telerik.Web.UI" assembly="Telerik.Web.UI" />
          </controls>
        </pages>
        <httpHandlers>
          <remove verb="*" path="*.asmx" />
          <add verb="*" validate="false" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler, Telerik.Web.UI" />
          <add verb="*" path="Telerik.RadUploadProgressHandler.ashx" type="Telerik.Web.UI.Upload.RadUploadProgressHandler, Telerik.Web.UI" />
          <add verb="*" path="Telerik.Sitefinity.FilesDownloadHandler.ashx" type="Telerik.Sitefinity.Modules.Files.FilesDownloadHandler, Telerik.Sitefinity" />
          <add verb="*" path="Telerik.Sitefinity.LibrariesRadUploadHandler.ashx" type="Telerik.Sitefinity.Modules.Libraries.Web.LibrariesRadUploadHandler, Telerik.Sitefinity" />
          <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false" />
          <add verb="*" path="*.svc" type="System.ServiceModel.Activation.HttpHandler, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
          <add verb="*" validate="false" path="Telerik.Web.UI.DialogHandler.axd" type="Telerik.Web.UI.DialogHandler, Telerik.Web.UI" />
          <add verb="*" path="Telerik.Sitefinity.AsyncImageUploadHandler.ashx" type="Telerik.Sitefinity.Modules.Libraries.Web.AsyncImageUploadHandler, Telerik.Sitefinity" />
        </httpHandlers>
        <httpModules>
          <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add name="Sitefinity" type="Telerik.Sitefinity.Web.SitefinityHttpModuleIIS6, Telerik.Sitefinity" />
          <add name="RadUploadModule" type="Telerik.Web.UI.RadUploadHttpModule, Telerik.Web.UI" />
          <add name="SitefinityAnalyticsModule" type="Telerik.Sitefinity.Analytics.Server.DependencyResolution.Module.DependencyRegistrarHttpModule, Telerik.Sitefinity.Analytics.Server.DependencyResolution" />
        </httpModules>
      </system.web>
      <system.serviceModel>
        <bindings>
          <basicHttpBinding>
            <binding name="basicHttpBinding" maxReceivedMessageSize="2147483647" maxBufferSize="2147483647">
              <security mode="None" />
            </binding>
          </basicHttpBinding>
        </bindings>
        <behaviors>
          <endpointBehaviors>
            <behavior name="SitefinityWebApp.Sitefinity.Services.Content.EventsAspNetAjaxBehavior">
              <enableWebScript />
            </behavior>
          </endpointBehaviors>
          <serviceBehaviors>
            <behavior name="Telerik.Sitefinity.Analytics.Infrastructure.Services.AnalyticsPermissionsServiceBehavior">
              <serviceMetadata httpGetEnabled="true" />
              <serviceDebug includeExceptionDetailInFaults="false" />
            </behavior>
            <behavior name="Telerik.Sitefinity.Analytics.Server.GoogleAnalyticsPlugin.Services.AccountsServiceBehavior">
              <serviceMetadata httpGetEnabled="true" />
              <serviceDebug includeExceptionDetailInFaults="false" />
            </behavior>
            <behavior name="Telerik.Sitefinity.Analytics.Infrastructure.Services.DashboardDataBehavior">
              <serviceMetadata httpGetEnabled="true" />
              <serviceDebug includeExceptionDetailInFaults="false" />
            </behavior>
            <behavior name="Telerik.Sitefinity.Analytics.Infrastructure.Services.MapDataServiceBehavior">
              <serviceMetadata httpGetEnabled="true" />
              <serviceDebug includeExceptionDetailInFaults="false" />
            </behavior>
          </serviceBehaviors>
        </behaviors>
        <services>
          <service name="SitefinityWebApp.Sitefinity.Services.Content.Events">
            <endpoint address="" behaviorConfiguration="SitefinityWebApp.Sitefinity.Services.Content.EventsAspNetAjaxBehavior" binding="webHttpBinding" contract="SitefinityWebApp.Sitefinity.Services.Content.Events" />
          </service>
          <service behaviorConfiguration="Telerik.Sitefinity.Analytics.Infrastructure.Services.AnalyticsPermissionsServiceBehavior" name="Telerik.Sitefinity.Analytics.Infrastructure.Services.AnalyticsPermissionsService">
            <endpoint address="" binding="basicHttpBinding" bindingConfiguration="basicHttpBinding" contract="Telerik.Sitefinity.Analytics.Infrastructure.Services.AnalyticsPermissionsService" />
          </service>
          <service behaviorConfiguration="Telerik.Sitefinity.Analytics.Server.GoogleAnalyticsPlugin.Services.AccountsServiceBehavior" name="Telerik.Sitefinity.Analytics.Server.GoogleAnalyticsPlugin.Services.AccountsService">
            <endpoint address="" binding="basicHttpBinding" bindingConfiguration="basicHttpBinding" contract="Telerik.Sitefinity.Analytics.Server.GoogleAnalyticsPlugin.Services.AccountsService" />
          </service>
          <service behaviorConfiguration="Telerik.Sitefinity.Analytics.Infrastructure.Services.DashboardDataBehavior" name="Telerik.Sitefinity.Analytics.Infrastructure.Services.DashboardData">
            <endpoint address="" binding="basicHttpBinding" bindingConfiguration="basicHttpBinding" contract="Telerik.Sitefinity.Analytics.Infrastructure.Services.DashboardData" />
          </service>
          <service behaviorConfiguration="Telerik.Sitefinity.Analytics.Infrastructure.Services.MapDataServiceBehavior" name="Telerik.Sitefinity.Analytics.Infrastructure.Services.MapDataService">
            <endpoint address="" binding="basicHttpBinding" bindingConfiguration="basicHttpBinding" contract="Telerik.Sitefinity.Analytics.Infrastructure.Services.MapDataService" />
          </service>
        </services>
        <serviceHostingEnvironment aspNetCompatibilityEnabled="true" />
      </system.serviceModel>
      <system.codedom>
        <compilers>
          <compiler language="c#;cs;csharp" extension=".cs" warningLevel="4" type="Microsoft.CSharp.CSharpCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
            <providerOption name="CompilerVersion" value="v3.5" />
            <providerOption name="WarnAsError" value="false" />
          </compiler>
          <compiler language="vb;vbs;visualbasic;vbscript" extension=".vb" warningLevel="4" type="Microsoft.VisualBasic.VBCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
            <providerOption name="CompilerVersion" value="v3.5" />
            <providerOption name="OptionInfer" value="true" />
            <providerOption name="WarnAsError" value="false" />
          </compiler>
        </compilers>
      </system.codedom>
      <!--
            The system.webServer section is required for running ASP.NET AJAX under Internet
            Information Services 7.0.  It is not necessary for previous version of IIS.
        -->
      <system.webServer>
        <validation validateIntegratedModeConfiguration="false" />
        <modules>
          <remove name="UrlRoutingModule" />
          <remove name="ScriptModule" />
          <remove name="RadUploadModule" />
          <remove name="Sitefinity" />
          <remove name="SitefinityAnalyticsModule" />
          <add name="ScriptModule" preCondition="managedHandler" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add name="Sitefinity" type="Telerik.Sitefinity.Web.SitefinityHttpModule, Telerik.Sitefinity" />
          <add name="RadUploadModule" type="Telerik.Web.UI.RadUploadHttpModule, Telerik.Web.UI" />
          <add name="SitefinityAnalyticsModule" type="Telerik.Sitefinity.Analytics.Server.DependencyResolution.Module.DependencyRegistrarHttpModule, Telerik.Sitefinity.Analytics.Server.DependencyResolution" />
        </modules>
        <handlers>
          <remove name="ScriptHandlerFactory" />
          <remove name="ScriptHandlerFactoryAppServices" />
          <remove name="ScriptResource" />
          <remove name="UrlRoutingHandler" />
          <remove name="WcfHandler" />
          <remove name="WildCard" />
          <remove name="Telerik.Web.UI.DialogHandler" />
          <remove name="Telerik.RadUploadProgressHandler" />
          <remove name="Telerik.Sitefinity.FilesDownloadHandler" />
          <remove name="Telerik.Sitefinity.LibrariesRadUploadHandler" />
          <remove name="Telerik.Sitefinity.AsyncImageUploadHandler" />
          <remove name="Telerik.Web.UI.SpellCheckHandler" />
                <add name="Wildcard" path="*" verb="*" modules="IsapiModule" scriptProcessor="C:\Windows\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll" resourceType="Unspecified" requireAccess="None" preCondition="classicMode,runtimeVersionv2.0,bitness32" />
           
          <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add name="UrlRoutingHandler" preCondition="integratedMode" verb="*" path="UrlRouting.axd" type="System.Web.HttpForbiddenHandler, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
          <add name="WcfHandler" path="*.svc" verb="*" type="System.ServiceModel.Activation.HttpHandler, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" resourceType="Unspecified" preCondition="integratedMode" />
          <add name="Telerik.Web.UI.DialogHandler" path="Telerik.Web.UI.DialogHandler.axd" verb="*" type="Telerik.Web.UI.DialogHandler, Telerik.Web.UI" />
          <add name="Telerik.RadUploadProgressHandler" path="Telerik.RadUploadProgressHandler.ashx" verb="*" type="Telerik.Web.UI.Upload.RadUploadProgressHandler, Telerik.Web.UI" />
          <add name="Telerik.Sitefinity.FilesDownloadHandler" path="Telerik.Sitefinity.FilesDownloadHandler.ashx" verb="*" type="Telerik.Sitefinity.Modules.Files.FilesDownloadHandler, Telerik.Sitefinity" />
          <add name="Telerik.Sitefinity.LibrariesRadUploadHandler" path="Telerik.Sitefinity.LibrariesRadUploadHandler.ashx" verb="*" type="Telerik.Sitefinity.Modules.Libraries.Web.LibrariesRadUploadHandler, Telerik.Sitefinity" />
          <add name="Telerik.Sitefinity.AsyncImageUploadHandler" path="Telerik.Sitefinity.AsyncImageUploadHandler.ashx" verb="*" type="Telerik.Sitefinity.Modules.Libraries.Web.AsyncImageUploadHandler, Telerik.Sitefinity" />
          <add name="Telerik.Web.UI.SpellCheckHandler" verb="*" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler, Telerik.Web.UI" />
     
        </handlers>
            <defaultDocument>
                <files>
                    <remove value="login.aspx" />
                </files>
            </defaultDocument>
      </system.webServer>
      <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1" appliesTo="v2.0.50727">
          <dependentAssembly>
            <assemblyIdentity name="System.Web.Extensions" publicKeyToken="31bf3856ad364e35" />
            <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0" />
          </dependentAssembly>
          <dependentAssembly>
            <assemblyIdentity name="System.Web.Extensions.Design" publicKeyToken="31bf3856ad364e35" />
            <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0" />
          </dependentAssembly>
        </assemblyBinding>
      </runtime>
    </configuration>
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    06 Sep 2010
    Link to this post
    Hello Dave,

    Thank you for using our services.

    In the Sitefinity back end we make use of WCF services to serve all types of content. This issue looks like there is a problem with WCF services on IIS. Most probably the http handlers are not correctly mapped. Can you please take a look at your IIS configuration and see if you have .svc extension added in handler mappings for the website. You can refer to attached image. The .svc extension should be mapped to the following handler: System.ServiceModel.Activation.HttpHandler, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089.

    Kind regards,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Dave
    Dave avatar
    8 posts
    Registered:
    10 Jun 2008
    08 Sep 2010
    Link to this post
    I checked that and it seems that it is setup correctly (see attached image).  Could this have an issue because I am also running some .NET 4.0 WCF services?
  4. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    08 Sep 2010
    Link to this post
    Hi Dave,

    This should not be a problem. If you can see at the screen shot I have provided I also have a handler mapping for .NET 4.0 services in the same website. You should note however that the Sitefinity 4.0 Beta websites do not support .NET 4.0 yet. Please check if you are targeting .NET 4.0 framework and if your application pool is running in .NET 4.0. If yes please create an application pool which is not running in .NET 4.0

    Sincerely yours,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Dave
    Dave avatar
    8 posts
    Registered:
    10 Jun 2008
    08 Sep 2010
    Link to this post
    No it is setup to run in 3.5 in Integrated Mode.  (see screenshot below)
  6. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    08 Sep 2010
    Link to this post
    Hello Dave,

    Thank you for getting back to me.

    Please make sure that the WebDAV module is disabled as described in this KB Article. Make sure that your website is using Anonymous and Forms Authentication. Also when you get the error check in FireBug for FF or in IE Developer Tools what is the exact response returned from the request to the services.

    All the best,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Dave
    Dave avatar
    8 posts
    Registered:
    10 Jun 2008
    08 Sep 2010
    Link to this post
    Hello,

    Thanks for all your help.  I verified that both Forms and Anonymous Authentication is turned on.  I also added the line to remove the WebDavModule to the web.config.  The same issue is still occurring.  Here is the request from Firebug:

    GET /login.aspx?ReturnUrl=%2fSitefinity%2fServices%2fPages%2fPagesService.svc%2f%3fmanagerType%3d%26providerName%3d%26itemType%3dTelerik.Sitefinity.Pages.Model.PageData%26provider%3d%26sortExpression%3dTitle%2520ASC%26skip%3d0%26take%3d50&managerType=&providerName=&itemType=Telerik.Sitefinity.Pages.Model.PageData&provider=&sortExpression=Title%20ASC&skip=0&take=50 HTTP/1.1
    Host: 192.168.1.246
    User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
    Accept-Language: en-us,en;q=0.5
    Accept-Encoding: gzip,deflate
    Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
    Keep-Alive: 115
    Connection: keep-alive
    Referer: http://192.168.1.246/Sitefinity/Pages
    Cookie: .SFAUTH=74257AEF5F22B387F03153D776858F445475BA3BB331616E8341CFED58F5268D821B2BE5D29CBB07430146BD4752C03BA607A292C66BD0DA183DB05CCCD4A952B552B72A66D86DEB68BA920635801DC1F596C6130BD2539E69DEE926FCFAA0E99BD5A641C924E519B65388DBA43A38751F189FBB5FE47BDBFE0442383B8CE40EC9F0B3B6A18D66DBF03E474F5B785ECEBF4E83F2144CFBFCE4489C75A39AE5D96C001D7412A5E86F3107493A81AD320BF74949E344D19F5301EE012D9AAF4587; .SFROLES=V23FjmXcRq0w2EnitOpdT9So85rXdePIo0FWlTi3258SASiqBBElLdZcTAQ53O854MBlm/1UKebDRJPImHVlfG0PYwfRW0y29twwKyOxz/hP7HVWkVKG93PYWjT6Exi9H2hrrbigkNbqhB6wLBofwznTpB/Lxoerdh3Z9DjHpzpwotTYPc58fQPrdkpVT7DM8R5RIAC3rDf05UF4unoijuz573008F7fW2a8mgYEqU09IBMwYzlAABpiwlO+CWSQLDymjRjTRbOKbFJf2WaXbZ5Cp3pQwU3UMmHuQh38Q/XGmp3E0uANOpUkK8Bs6nRAQWVvKO2EpuWjlptp3gSP//AcG7JW0ugMIVKsHmk9rhGbYt9gkfjFf91Q5u+7kfPU/1jcavF39YmhmoNret0DWx0duvgorLKeREv9T+JKrVUdTTpFdzrsBRx9BiWWd2ssfBlGcj2eaKTHels0MLzgAY8I2+n8y9Xa2Nq2dnQEF3jxeTKFdF+H+7Nsg5rj7ct5GKaQVv8rmvK9P5bwwq/RaqB00apuB1JMdT7A28rJevp6Hte7E58d4XYjTQij1UsRUN+NiXd8GKkZtuTWgUboH2+V1/zZUbQ+nafM2Fo6NAnC0dBIdaapSdS1a734cWlUrFFMIJwFYXFy0hzBlPWrJAZ+jSjYOBQlx5FmlaH5dKFbOXTdSKaG+P4BAAA=
    
    

    Here is the Response:
    HTTP/1.1 404 Not Found
    Cache-Control: private
    Content-Type: text/html; charset=utf-8
    Server: Microsoft-IIS/7.5
    X-AspNet-Version: 2.0.50727
    X-Powered-By: ASP.NET
    Date: Wed, 08 Sep 2010 14:45:09 GMT
    Content-Length: 3037
    
  8. Dave
    Dave avatar
    8 posts
    Registered:
    10 Jun 2008
    09 Sep 2010
    Link to this post
    I have also tried creating a new site completely from scratch using the Project Manager tool.  This does not work when I try to browse to the Administration section.  I keep getting redirected to:

    http://localhost:53092/SupportTest/login.aspx?ReturnUrl=%2fSupportTest%2fdefault.aspx

    Even when I browse to the default page it looks wrong:

    http://localhost:53092/SupportTest/login.aspx?ReturnUrl=%2fSupportTest%2fsitefinity%2fdefault.aspx

    Any ideas what is going on? 


    I don't know if this matters but I am running all this on Windows 7 with IIS 7.5.
  9. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    10 Sep 2010
    Link to this post
    Hello Dave,

    Can you please tell us what is wrong with the url? It looks correct to me. When you create new projects with the project manager the default location for creating projects is on the file system. The project manager uses its own integrated web server for development so by default it is using this server for developing projects. If you wish to create a project on IIS you can follow the steps from the attached video (taken from Windows 7 Enterprise and IIS 7.5).

    All the best,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  10. Daniel
    Daniel avatar
    35 posts
    Registered:
    15 Jun 2010
    10 Sep 2010
    Link to this post
    Hello Dave,

    I had the same issues while trying to configure SF4 to run on ISS 6. Whenever I clicked on Pages or Libraries it would just display a "Resource cannot be found" message box. I needed the website to be secured with Windows Authentication to limit access to it. Using the Developer tools from Chrome I noticed that when browsing the Pages section or the Libraries section the website was also redirecting to that login.aspx page, returning a 404 error.

    To solve this issue I did the following:

    1st. Activate Windows Authentication on the root of the SF4 site or virtual directory.
    2nd. Apply ONLY Anonymous Authentication to the directory ~/Sitefinity and sub-directories (where the .svc files are).

    Everything started working after I performed this.

    Also, if you are using the Publish option on Visual Studio 2010 to Publish your website, please make sure you first toggle the Show All Files and include everything under that folder (every sub folder and file) in the project. The solution doesn't come with all those files loaded and as such Publish will only copy the files which are included in the Project so you need to add them all up.

    Check if it works for you!

    Regards,
    Daniel
  11. Dave
    Dave avatar
    8 posts
    Registered:
    10 Jun 2008
    10 Sep 2010
    Link to this post
    The URL's I posted all redirect to a nonexistant login.aspx page even when I am just trying to hit the Default page:

    http://localhost:53092/SupportTest/login.aspx?ReturnUrl=%2fSupportTest%2fdefault.aspx

    This appears to me like your integrated server is trying to use forms authentication, failing and redirecting to a login page.  The issue is it does this for the main as well as the admin section.  Both pages are then redirected to the dummy page you guys have setup.  Why is this?
  12. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    14 Sep 2010
    Link to this post
    Hi Dave,

    Sitefinity 4.0 uses extensionless URLs. The links you have posted contains URLs. If you take a look at the attached video you will see that when a website is browsed (open PM and click go to administration) it spools up the integrated server and tries to navigate to /Sitefinity. If you are not authenticated you will be redirected to the login page which is /Sitefinity/Login and the return url will be http://localhost:20442/NewProject/Sitefinity/Login?ReturnUrl=/NewProject/Sitefinity/.

    Can you please record a sample webcast of the described behavior on your machine. We are failing to reproduce this using websites created on the file system (not on IIS)? Also make sure that you have .NET 3.5 framework installed.

    Regards,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  13. peter shitote
    peter shitote avatar
    5 posts
    Registered:
    17 Mar 2010
    19 Sep 2010
    Link to this post
    I have been working days on end trying to figure out how to configure my sitefinity 4 beta to work with IIS7. Finally, I got a solution, which I believe most of you who are developing in sitefinity would be interested in. If you are getting an error accessing the "Page" link in sitefinity web app, perhaps Windows is denying you permission to access some resources through IIS. Check the application pool you are using and make sure it is defaultapplication pool (remember to configure defaultapplication pool to run on Network Service). Then navigate to the physical file location (location in your hard disk) where you installed sitefinity website. Right click the folder then under "Security tab" click Edit > Add. Type "Network Service" in the text box shown at the bottom of the dialog. Click Ok. Now give "Full Control" permission to this user. You can also give full control to "Local Service" in place of network service depending on the user SQL Server is running on.

    Regards,
    Peter Shitote
13 posts, 0 answered