More in this section
Forums / General Discussions / Help understanding Sitemap generation and url link

Help understanding Sitemap generation and url link

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
1 posts, 0 answered
  1. Scott
    Scott avatar
    3 posts
    11 Dec 2014
    15 Aug 2016
    Link to this post

    We have a Sitefinity 8.0 site and our Sitemaps were working at one point but have recently broken and I can't for the life of me figure out how to diagnose and fix the issue.

    When I generate a new sitemap, it runs through the process and says "Sitemap generated successfully".  However the urls don't work.  The domain names in the urls are correct and match the site, but both the index and the sitemap files return a status=200 but give the following error:

    HttpException: File not found.

    at Telerik.Sitefinity.Modules.Libraries.Web.LibraryHttpHandler.GetOutputItem(HttpRequestBase request, HttpResponseBase response, ICacheManager cache, String key, MediaContent& content)
    at Telerik.Sitefinity.Modules.Libraries.Web.LibraryHttpHandler.ProcessRequest(HttpContextBase context)
    at Telerik.Sitefinity.Modules.Libraries.Web.LibraryHttpHandler.ProcessRequest(HttpContext context)
    at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
    at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)


    I think the error is likely one of two issues:

    1) Maybe the sitemap isn't actually generating and saving correctly.  Where would I look to find this?  Our default blobs provider is FileSystem, but I've tried with Database as well and don't see anything.

    2) Perhaps the routing is messed up and the /sitemap/ route isn't going to the generator/handler correctly.  I can't figure out how to tell what is happening routing wise though, so any ideas would be appreciated

    Also, the Sitefinity error and trace logs show only the same error above without any  additional useful info as far as I can tell.


1 posts, 0 answered