More in this section

Forums / General Discussions / Importing RSS feed to Custom Provider blog

Importing RSS feed to Custom Provider blog

4 posts, 0 answered
  1. Susan
    Susan avatar
    14 posts
    Registered:
    08 Oct 2007
    23 Feb 2012
    Link to this post
    In order to change the URL format of blog posts, I've implemented a custom blog provider as documented here: http://www.sitefinity.com/blogs/slavoingilizov/posts/11-10-19/custom_url_formats_for_sitefinity_content_modules.aspx  Once complete, I created a new blog, and I can post as normal to it.

    Next step I need to import an external feed into this blog. I set up the import feed in the Feeds and Notifications, but when I go to select what blog to import to, there is nothing in the list. It looks like the blog selection isn't seeing the custom provider-based blog.

    If I repeat the steps using the default OpenAccessDataProvider, everything works correctly.

    How do I set it up so I can import to my custom blog?


    EDIT TO ADD: This appears to be a global issue. If I try and configure the custom provider blog on the blog widget, the Choose Blogs list appears empty there as well.
  2. Svetoslav Petsov
    Svetoslav Petsov avatar
    456 posts
    Registered:
    24 Sep 2012
    28 Feb 2012
    Link to this post
    Hi Steve,

     Unfortunately the way our content selectors are currently implemented, they are bound directly to the content service and they do not pass the provider as a parameter. This means that the built-in selectors won't let you select blogs from your custom provider and the only way to create a feed for a custom provider of blogs would be through code.

    All the best,
    Svetoslav Petsov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Susan
    Susan avatar
    14 posts
    Registered:
    08 Oct 2007
    28 Feb 2012
    Link to this post
    Any chance I could submit a feature request in to include passing the provider? Or is that just not possible with the way the framework is set up?
  4. Svetoslav Petsov
    Svetoslav Petsov avatar
    456 posts
    Registered:
    24 Sep 2012
    02 Mar 2012
    Link to this post
    Hello Steve,

     I logged this as a feature request. Here's the PITS item that you can follow:
    http://www.telerik.com/support/pits.aspx#/public/sitefinity/10025 

    Regards,
    Svetoslav Petsov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
4 posts, 0 answered