More in this section

Forums / General Discussions / Language selector and home page

Language selector and home page

4 posts, 1 answered
  1. Millaneli
    Millaneli avatar
    20 posts
    Registered:
    08 Nov 2010
    09 Dec 2010
    Link to this post

    Hi,

    I have a problem with language selector when I put this url http://localhost:58632/nom_projet/ but if I put this url http://localhost:58632/nom_projet/fr/ the exception does not exist.

  2. Petya
    Petya avatar
    123 posts
    Registered:
    30 May 2017
    11 Dec 2010
    Link to this post
    Hi Millaneli,


    Are you using a template for your home page? If your home page is based on a page template that contains a language selector control then it throws this exception. Please, tell me if you are setting your home page in a similar way.

    I can reproduce this issue following the steps below and there is a bug logged for this scenario.

    1. Enable multilingual mode with two languages
    2. Create a template with a language selector control
    3. Create a page using this template and set this page as a home page
    4. Navigate to the project  and  "Object reference not set to an instance of an object" error is thrown


    Best wishes,
    Petya
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Millaneli
    Millaneli avatar
    20 posts
    Registered:
    08 Nov 2010
    15 Dec 2010
    Link to this post
    Hi,

    Yes, I use a template for my pages, but I am not put the "Language Selector" in the template.

    I used this control in the page and the problem still exists if I put http://localhost:26138/My_Projetc/en/ in my browser it works fine, but if I do it http://localhost:26138/My_Project/ does not work!!!!!

  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    16 Dec 2010
    Link to this post
    Hello Millaneli,

    We managed to replicate the issue and fix it in the code. The fix will appear in the weekly build that we will have next week.

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
4 posts, 1 answered