More in this section

Forums / General Discussions / Library, Images, Video & Documents missing

Library, Images, Video & Documents missing

10 posts, 1 answered
  1. Keivan Kechmiri
    Keivan Kechmiri avatar
    38 posts
    Registered:
    16 Aug 2009
    23 Nov 2010
    Link to this post
    Hi

    My Images, Video & Documents are gone from the Backend menu after upgrade to RC and after adding another language (Swedish) and change to new Default language (Swedish). They are still in the system but not in the menu. I can't find them if I go into the Backend Admin.

    How can Iget them back?

    /Keivan
  2. Keivan Kechmiri
    Keivan Kechmiri avatar
    38 posts
    Registered:
    16 Aug 2009
    23 Nov 2010
    Link to this post
    I haven't deleted these from Backend Pages in Admin.

    I've Tried to add these back manually, duplicating another page like News and changing ControlDefinitionName & ModuleName, but I get the following error:

    Any solution?

    /Keivan

    Object reference not set to an instance of an object.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [NullReferenceException: Object reference not set to an instance of an object.]
       Telerik.Sitefinity.Web.RouteHelper.<ResolveUrl>b__0(String type, String value, String options) +292
       System.Text.RegularExpressions.RegexReplacement.Replace(MatchEvaluator evaluator, Regex regex, String input, Int32 count, Int32 startat) +301
       System.Text.RegularExpressions.Regex.Replace(String input, MatchEvaluator evaluator) +67
       Telerik.Sitefinity.Web.RouteHelper.ResolveUrl(String url, UrlResolveOptions urlOptions) +333
       Telerik.Sitefinity.Web.UI.ContentUI.Views.Backend.Master.MasterGridView.SetLinks(IList`1 links, ItemsListBase itemsList) +525
       Telerik.Sitefinity.Web.UI.ContentUI.Views.Backend.Master.MasterGridView.InitializeControls(GenericContainer container, IContentViewDefinition definition) +2218
       Telerik.Sitefinity.Web.UI.ContentUI.Views.Backend.ViewBase.CreateChildControls() +88
       System.Web.UI.Control.EnsureChildControls() +181
       System.Web.UI.WebControls.CompositeControl.get_Controls() +23
       Telerik.Sitefinity.Web.UI.ContentUI.ContentView.LoadView(String viewName) +538
       System.Web.UI.Control.EnsureChildControls() +181
       System.Web.UI.Control.PreRenderRecursiveInternal() +59
       System.Web.UI.Control.PreRenderRecursiveInternal() +221
       System.Web.UI.Control.PreRenderRecursiveInternal() +221
       System.Web.UI.Control.PreRenderRecursiveInternal() +221
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +4184
    
  3. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    25 Nov 2010
    Link to this post
    Hi Keivan Kechmiri,

    Thank you for using our services.

    I have tried reproducing your issue by following the bellow steps:

    1) Create a website using Sitefinity 4.0 Beta 2 (build 676)
    2) Fill it up with some content and images
    3) Upgrade the website using the Upgrade button in Project Manager to Sitefinity 4.0 RC (build 910)
    4) Go to the back-end and add a new language for localization (Swedish) and set it as default.
    5) Add Swedish as default back-end language.

    There are no changes to the back-end pages and they all appear correct. Am I missing a step?

    All the best,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  4. Keivan Kechmiri
    Keivan Kechmiri avatar
    38 posts
    Registered:
    16 Aug 2009
    25 Nov 2010
    Link to this post
    Hi

    I can't really say what's happende I only really know that the pages are gone from the Backend Pages, and I haven't been in that section util I this problem appeared.

    I've tried to add the pages back by trying to duplicate Events page and chaning ControlDefinitionName & ModuleName to for example DocumentsBackend/Libraries for the "new" Libraries page (duplicated from Events). I tried to exactly duplicate the missing pages using a new install as a Template.

    When I try to open the "new" page I get Object reference not set to an instance of an object. in the page designer & if i try to View the page a get a error (below).

    I've also tried to ta a look at the database to see if I could find the missing pages, but it was a little difficult to figure the DB scructure, but as far as I can see the pages wasn't inte the DB.

    I've also tried to check Advanced Settings/System/ApplicationModules/Libraries, after the upgrade the Version was empty, and the Type wasn't the same as a new install, copied settings from the new install, but no luck.

    /Keivan

    Object reference not set to an instance of an object.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [NullReferenceException: Object reference not set to an instance of an object.]
       Telerik.Sitefinity.Web.RouteHelper.<ResolveUrl>b__0(String type, String value, String options) +292
       System.Text.RegularExpressions.RegexReplacement.Replace(MatchEvaluator evaluator, Regex regex, String input, Int32 count, Int32 startat) +301
       System.Text.RegularExpressions.Regex.Replace(String input, MatchEvaluator evaluator) +67
       Telerik.Sitefinity.Web.RouteHelper.ResolveUrl(String url, UrlResolveOptions urlOptions) +333
       Telerik.Sitefinity.Web.UI.ContentUI.Views.Backend.Master.MasterGridView.SetLinks(IList`1 links, ItemsListBase itemsList) +525
       Telerik.Sitefinity.Web.UI.ContentUI.Views.Backend.Master.MasterGridView.InitializeControls(GenericContainer container, IContentViewDefinition definition) +2218
       Telerik.Sitefinity.Web.UI.ContentUI.Views.Backend.ViewBase.CreateChildControls() +88
       System.Web.UI.Control.EnsureChildControls() +181
       System.Web.UI.WebControls.CompositeControl.get_Controls() +23
       Telerik.Sitefinity.Web.UI.ContentUI.ContentView.LoadView(String viewName) +538
       System.Web.UI.Control.EnsureChildControls() +181
       System.Web.UI.Control.PreRenderRecursiveInternal() +59
       System.Web.UI.Control.PreRenderRecursiveInternal() +221
       System.Web.UI.Control.PreRenderRecursiveInternal() +221
       System.Web.UI.Control.PreRenderRecursiveInternal() +221
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +4184
    
  5. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    25 Nov 2010
    Link to this post
    Hello Keivan Kechmiri,

    Thank you for getting back to us.

    This issue is very strange. I am still failing to reproduce. Can you please open up a bug report and send us you project and database? We will download your project and set it up locally to and debug what might be wrong. It will also be nice if you create an admin user for us and give us the credentials.

    Thank you for your cooperation in advance.

    Best wishes,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
  6. Keivan Kechmiri
    Keivan Kechmiri avatar
    38 posts
    Registered:
    16 Aug 2009
    25 Nov 2010
    Link to this post
    I've created a support ticket (370609).

    /Keivan
  7. Ed Sirijintakarn
    Ed Sirijintakarn avatar
    19 posts
    Registered:
    02 Feb 2010
    25 Nov 2010
    Link to this post
    Hello, and Happy Thanksgiving to everyone that resides in the United States -- I *may* be having the same issue?  I've added an additional language (Thai) a few days ago, played around with the RC some more, and have since noticed that I can't find a way to manage any library images.  I'm new to SF 4, but I image that there would be a link to the library from one of the menus.  Will try to reproduce this on a separate instance while the turkey is roasting in the oven :-)

    Ed Sirijintakarn
    Internetiks, Inc.
  8. Ed Sirijintakarn
    Ed Sirijintakarn avatar
    19 posts
    Registered:
    02 Feb 2010
    25 Nov 2010
    Link to this post
    Well, I've been trying to break a new instance for the past 2 hours and was unable to duplicate the fact that "Images, Video, and Documents" are missing from the "Content" menu (see attached images of the original instance and the new).

    The only thing I got out of it however was that if I tried to manually type in the link to "Images" ( /Sitefinity/Content/Images ) in the original instance, it results in a "404 - The resource cannot be found."

    Note, yes I am logged in as an admin in both instances.

    Ed Sirijintakarn
    Internetiks, Inc.
  9. Keivan Kechmiri
    Keivan Kechmiri avatar
    38 posts
    Registered:
    16 Aug 2009
    26 Nov 2010
    Link to this post
    Hi

    I've got the solution from Support, do as follows to resolve the problem.
    Go to: Administration/Settings/Advanced/System/ApplicationModules/Libraries

    * Remove Version info (if any)
    * Change StartUpType to OnFirstCall

    Restart Sitefinity (Recycle Application Pool or make a dummy change to web.config)

    /Keivan
  10. Ed Sirijintakarn
    Ed Sirijintakarn avatar
    19 posts
    Registered:
    02 Feb 2010
    29 Nov 2010
    Link to this post
    Yep, this fixed it for me as well.  Strange - I wonder how these got changed in the first place...

    Ed Sirijintakarn
    Internetiks, Inc.
10 posts, 1 answered