More in this section

Forums / General Discussions / Missing assembly after upgrading to 4.1

Missing assembly after upgrading to 4.1

2 posts, 0 answered
  1. Suzanne
    Suzanne avatar
    43 posts
    Registered:
    12 Jul 2012
    22 Apr 2011
    Link to this post
    I've upgraded my 4.0 project to 4.1 and when trying to browse to the site the following error is being displayed. The version of Telerik.OpenAccess.dll that the site is referencing is 2011.1.411.2.

    Could not load file or assembly 'Telerik.OpenAccess.Config, Version=1.0.0.0, Culture=neutral, PublicKeyToken=7ce17eeaf1d59342' or one of its dependencies. The system cannot find the file specified.


  2. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    23 Apr 2011
    Link to this post
    Dear Suzanne

    This might not help but I had trouble often with missing aaa.dll or one of its dependencies. Fictional dll and version numbers

    Lets say you have telerik
    a.dll versin 2010.3.111.4 and it needs
    a1.dll 2010.3.111.4 as well as
    a2.dll 2010.3.111.4

    When you up upgrade
    a.dll to 2011.1.111.1 you also needed to upgrade
    a1.dll to 2011.1.111.1 as well as
    a2.dll to 2011.1.111.1

    No to me once in a while it seemd (if I rember correct) that when you upgrade to

    a.dll 2011.2.889.1 you it would no longer depend on a2.dll

    So I uploaded the
    a.dll 2011.2.889.1 as well as the new
    a1.dll 2011.2.889.1

    Since there was no

    a2.ddl with version 2011.2.889.1 anymore the old
    a2.dll with version 2011.1.111.1 would not be overritten. This dll which is no longer needed would still be looking for a.dll with version 2011.1.111.1 which of course was replaced with the new version a.dll 2011.2.889.1 and would trow an error.

    ---------------
    It might be wrong what I am writing but I allways checke bottom down if all dependencies were on the server missing sometime older leftover ^child dlls' looking for parent dlls .

    If this is wrong anybody correct me. Otherwise it might be a starting point to see if any of your dll on the server is missing an assambly.


    This tool will help you http://checkasm.booring.net/ install it and drag an dll into the window and you see what its dependencies are. Again not only look top down, but bottom up as well.

    Markus

2 posts, 0 answered