More in this section

Forums / General Discussions / Module Builder - Custom Module Problem

Module Builder - Custom Module Problem

2 posts, 0 answered
  1. Darren
    Darren avatar
    4 posts
    Registered:
    21 Oct 2009
    03 Feb 2012
    Link to this post
    I have built a custom module, that was all working brilliant.  It has a number fo fields of varying types but includes both a single image uploader PLUS a document uploader that can allow multiple documents to upload.

    Today, I tried to extend the control further by adding two new fields, a new single image as well as a new long text.

    Long text...worked fine.  As soon as I added the new image field it messed with all of the existing images and uploaded documents and they lost their association with the individual CustomContentItems.

    I tried a number of things like deleting all uploaded items from each CustomContentItem, then re-attaching after the new field was added.
    Also, deleting all uploaded items from each CustomContentItem PLUS deleteing them from the libraries, then re-uploading/attaching after the new field was added.

    In each instance there were errors relating to not able to find content, content missing or similar messages.

    Has anyone seen anything similar, is this a known problem, anyone have suggestions for a work around as I really need this new image.

    thanks in advance.

    Darren


  2. Stoimen Stoimenov
    Stoimen Stoimenov avatar
    60 posts
    Registered:
    24 Aug 2017
    03 Feb 2012
    Link to this post
    Hello Darren,

    Thank you for contacting us.

    I spent some time investigating your issue and it turns out that this is very annoying bug that we have missed. I logged it as a PITS issue and you can vote for it and track its progress. However the names of the fields turned out to be important factor for reproducing this issue. If I name my image field "image2" when creating the module and then when I edit the fields I add an image field named "image1" and save it everything works as expected. But if I create a module with an image field "image1" and then I edit it to add a field "image2" I get the same mess as you.

    What I am curious about are the error messages you get when you delete images, libraries, content items and so on because I didn't get any warnings or errors. If you can provide more information about the error messages it will help us a lot to localize the problem and fix it.

    For now I am suggesting that you plan carefully what your module is going to look like and minimize the changes with fields editor because we are experiencing problems with it and we are doing our best to improve it for Sitefinity 5.0. Also build your module in a clean project and when you are sure what your module is going to look like recreate it in production environment.

    I apologize for any inconvenience this is causing.

    Regards,
    Stoimen Stoimenov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered