More in this section
Forums / General Discussions / Module is not displaying in content level

Module is not displaying in content level

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
2 posts, 0 answered
  1. Aloy
    Aloy avatar
    3 posts
    Registered:
    27 Sep 2014
    14 Sep 2016
    Link to this post

    Hi All,

    I have created one hierarchical level module in sitefinity 9.1 and publish it. But when i am trying to create data using it i am getting only first  level module and other lower level module is not available. i  have checked the back end pages also and i found everything is published. Please find the attach screenshot.

    Last but not the least i am using multisite environment.

    Please guide me. Thanks..

     

    Regards,

    Aloy

  2. Aloy
    Aloy avatar
    3 posts
    Registered:
    27 Sep 2014
    21 Sep 2016
    Link to this post

    Hi All,

    Its working fine now ..i just delete the existing module and create it again.. But now i have one serious issue,

    1. After creating and adding the content in module, i tried to fetch the data using DynamicModuleManager api. But none of the data is getting loaded. As i am using multi site environment i have use below code,

    var providerName = new MultisiteContext().CurrentSite.GetDefaultProvider("Leadership");
                    DynamicModuleManager dynamicModuleManager = DynamicModuleManager.GetManager(providerName.ProviderName.ToString());
                    Type LeadershipType = TypeResolutionService.ResolveType("Telerik.Sitefinity.DynamicTypes.Model.Leadership.Leadership");
                    var LeasdershipDetails = dynamicModuleManager.GetDataItems(LeadershipType).Where(i => i.Status == Telerik.Sitefinity.GenericContent.Model.ContentLifecycleStatus.Live && i.Visible == true).OrderByDescending(j => j.PublicationDate).ToList();

     

    But LeadershipDetails is appearing as null. This is happened to every module.Even if i create any new module then also i am getting the same issue. Please help me to solve it or else i will miss my delivery time line..

    Thanks in advance..

    Regards,

    Aloy

2 posts, 0 answered