More in this section
Forums / General Discussions / New to Telerik dll -Could not load file or assembly

New to Telerik dll -Could not load file or assembly

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
2 posts, 0 answered
  1. srividhya
    srividhya avatar
    1 posts
    Registered:
    15 Aug 2011
    15 Aug 2011
    Link to this post

    I am using the reference to the assembly in my aspx page,

    <%

     

    @ Register Assembly="Telerik.ReportViewer.WebForms, Version=5.1.11.713, Culture=neutral, PublicKeyToken=a9d7983dfcc261be"

     

     

     

    Namespace="Telerik.ReportViewer.WebForms" TagPrefix="telerik" %>

     


    I am getting
    Warning 1 C:\inetpub\wwwroot\Vincentric\Vincentric.Online\SingleVehicleReport.aspx: ASP.NET runtime error: Could not load file or assembly 'Telerik.Web.UI, Version=2010.1.309.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040) C:\inetpub\wwwroot\Vincentric\Vincentric.Online\SingleVehicleReport.aspx 1 1 Vincentric.Online

    We are upgrading from an older version of Teleric to the latest one.
    1) I changed the dlls to the new dlls in the ./bin directory (Telerik.Reporting.dll,Telerik.Reporting.Service.dll, Telerik.ReportViewer.WebForms.dll, Telerik.Web.UI.dll,Telerik.Web.UI.xml and deleted Telerik.Reporting.XamlRendering.dll)
    2) refreshed the reference to the new dlls in the project
    3) chenged the version from 4.0.10.310 to 5.1.11.713 for allTelerik.ReportViewer.WebForms references
    What else am i missing?


  2. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    17 Aug 2011
    Link to this post
    Hello Srividhya,

    Some of the assemblies in your /bin folder have their own reference to Telerik.Web.UI.dll - and to a specific version 2010.1.309.35 - do you have such .dll file in your /bin folder?

    Kind regards,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered