More in this section

Forums / General Discussions / No module builder options, empty screen

No module builder options, empty screen

2 posts, 0 answered
  1. Daniel Plomp
    Daniel Plomp avatar
    112 posts
    Registered:
    14 Jun 2012
    10 Jan 2012
    Link to this post
    Hi all,

    I wanted to create a new module, using the Module Builder. When I click the module builder option I get an empty screen. No option to create a new module.

    Here's the error that is inside the log file:
    ----------------------------------------
    Timestamp: 1/10/2012 12:35:56 PM
     
    Message: HandlingInstanceID: 19ee5cd9-e51f-429e-b98d-635d39fc9928
    An exception of type 'System.ServiceModel.EndpointNotFoundException' occurred and was caught.
    ---------------------------------------------------------------------------------------------
    01/10/2012 13:35:56
    Type : System.ServiceModel.EndpointNotFoundException, System.ServiceModel, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
    Message : The service '/weeseerlijk/Sitefinity/Services/DynamicModules/ContentTypeService.svc' does not exist.
    Source : System.ServiceModel.Activation
    Help link :
    Data : System.Collections.ListDictionaryInternal
    TargetSite : Void EnsureServiceAvailable(System.String)
    Stack Trace :    at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)
       at System.ServiceModel.ServiceHostingEnvironment.EnsureServiceAvailableFast(String relativeVirtualPath)
       at System.ServiceModel.Activation.HostedHttpRequestAsyncResult.HandleRequest()
       at System.ServiceModel.Activation.HostedHttpRequestAsyncResult.BeginRequest()
     
    Additional Info:
     
    MachineName : VMBP-DP
    TimeStamp : 1/10/2012 12:35:56 PM
    FullName : Telerik.Sitefinity.Utilities, Version=4.4.2117.0, Culture=neutral, PublicKeyToken=b28c218413bdf563
    AppDomainName : /LM/W3SVC/1/ROOT/weeseerlijk-4-129706725421455078
    ThreadIdentity : admin
    WindowsIdentity : IIS APPPOOL\ASP.NET v4.0
     
     
    Category: ErrorLog
     
    Priority: 0
     
    EventId: 90000
     
    Severity: Error
     
    Title:Enterprise Library Exception Handling
     
    Machine: VMBP-DP
     
    App Domain: /LM/W3SVC/1/ROOT/weeseerlijk-4-129706725421455078
     
    ProcessId: 5928
     
    Process Name: c:\windows\system32\inetsrv\w3wp.exe
     
    Thread Name:
     
    Win32 ThreadId:2536
     
    Extended Properties:
    ----------------------------------------

    What to do?

    Regards,
    Daniel
  2. Daniel Plomp
    Daniel Plomp avatar
    112 posts
    Registered:
    14 Jun 2012
    10 Jan 2012
    Link to this post
    Okay, I found out that there was no 'DynamicModules' directory under /Sitefinity/Services/
    Why that is, I don't know, but copied it from a new project, and now it works.

    Regards,
    Daniel
2 posts, 0 answered