More in this section
Forums / General Discussions / OpenAccessException when enabling diagnostics

OpenAccessException when enabling diagnostics

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
2 posts, 0 answered
  1. Bil
    Bil avatar
    51 posts
    Registered:
    27 Aug 2012
    05 Nov 2015
    Link to this post

    Hi guys,

    We're running 8.1 and I wanted to enable the diagnostics module. Installed the module but when I went to the diagnostics section in the Administration menu I got this error:

    Error
    Telerik.OpenAccess.OpenAccessException: SQL exception on 'CREATE DATABASE sitefinity-d_Diagnostics' : Incorrect syntax near '-'.

    Our database is named "sitename-d" (-d for dev, -t for test, etc.) so that's the only place I can see a "-". Does sitefinity have a problem with databases with this name when it comes to diagnostics (the rest of the site works fine). Is my only workaround to this renaming the database?

    Thanks

  2. Darrin Robertson
    Darrin Robertson avatar
    105 posts
    Registered:
    18 Jul 2004
    06 Nov 2015
    Link to this post
    Yes. You can not create a database with a hypen with Open Access.

    The module actually creates a new database to hold all its info. (It doesn't use your Sitefinity one). It uses yourSItefinityDB_Diagnostics.

    A way around it is to precreate the database. Then there is no need for it to try.

2 posts, 0 answered