More in this section

Forums / General Discussions / RadEditor Changing & to & in HTML tab.

RadEditor Changing & to & in HTML tab.

3 posts, 0 answered
  1. Jacob
    Jacob avatar
    5 posts
    Registered:
    20 Oct 2011
    10 Nov 2011
    Link to this post
    I'm trying to edit a URL that contains a '&' in the HTML tab, but each time, the editor replaces it with &, and this accordingly breaks the link.

    What can I do to resolve this?
  2. Jacob
    Jacob avatar
    5 posts
    Registered:
    20 Oct 2011
    11 Nov 2011
    Link to this post
    bump.
  3. Jen Peleva
    Jen Peleva avatar
    568 posts
    Registered:
    10 Nov 2016
    15 Nov 2011
    Link to this post
    Hi Jacob,

    We have already responded to the question in your support thread. For your convenience I'm posting the replay here as well.

    Indeed the RadEditor is converting the & character to its HTML presentation, but this should not affect the links that you add, because when the HTML in the editor is rendered the HTML presentation will be replaced by the actual character. Please review the attached screen cast. I have tested this behavior by adding query strings to my links, which were in turn properly rendered in the public part of the website.

    In order to disable the converting special character to HTML entities you must disable the respective content filter (ConvertCharactersToEntities) of the editor: Editor / Built-in Content Filters. To be able to modify the editor within Sitefinity you need to take the approach described in this blog post: Customizing the Sitefinity WYSIWYG Editor.

    Also there is a related forum thread that you might need to look at: Hyperlink Manager converts query string &amp.


    Regards,
    Jen Peleva
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
3 posts, 0 answered