More in this section
Forums / General Discussions / RadWindow not working in widget

RadWindow not working in widget

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
2 posts, 0 answered
  1. John
    John avatar
    97 posts
    11 Jan 2011
    10 Feb 2011
    Link to this post


    I have the following widget;

    <%@ Control Language="C#" AutoEventWireup="true" CodeBehind="ViewDocumentLauncher.ascx.cs"
        Inherits="SitefinityWebApp.Widgets.ViewDocument.ViewDocumentLauncher" %>
    <telerik:RadButton ID="btnViewDoc" runat="server" Text="Go for it!" SplitButtonCssClass=""
    <telerik:RadWindow ID="RadWindow1" runat="server" AutoSize="True" AutoSizeBehaviors="Width, Height"
        BackColor="#6699FF" Behaviors="Close, Move" Height="217px" KeepInScreenBounds="True"
        Modal="True" NavigateUrl="~/Widgets/TestWidgets/ViewDocument.aspx" OpenerElementID="btnViewDoc"
        Skin="Office2007" Title="Please read and accept document" VisibleStatusbar="False"

    Basically a radwindow has a button set as its OpenerElementID and radwindow’s NavigateUrl is set to an aspx page. Point is that pressing the button opens the radwindow with content of aspx page displayed.

    Problem is when button is pressed the page on which widget is, is refreshed but no radwindow appears.

    What is the issue and how can I make it work as intended?



  2. Steve
    Steve avatar
    3037 posts
    03 Dec 2008
    10 Feb 2011
    Link to this post
    Hmm, I would set AutoPostBack="False" on the RadButton to start with...perhaps if that doesnt immediatly work, do it the oldschool way and just write a clientside click handler for the button to call a .show on the window
2 posts, 0 answered