More in this section

Forums / General Discussions / SCSS Support?

SCSS Support?

7 posts, 0 answered
  1. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    06 Sep 2011
    Link to this post
    Hey Telerik,
      Have you guys had a chance to try and get LESS working with SF4 yet?  It's been KILLING me to not be able to play with in an SF4 context. 

    Thanks,
    Steve
  2. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    08 Sep 2011
    Link to this post
    Hello Steve,

    We haven't played with SCSS yet. We'll certainly take a look.
    Thanks for sharing!

    Greetings,
    Georgi
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

  3. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    08 Sep 2011
    Link to this post
    So I think (heads up) it has something to do with the App_Themes no longer being off the root (potentially)

    ...just not working
  4. Jordan
    Jordan avatar
    172 posts
    Registered:
    20 Oct 2015
    08 Sep 2011
    Link to this post
    Hello Steve,

     
    I have just tested this one with the example from the site, follow the instructions there and everything works fine: 

    @brand_color: #333;
     
    h1 {
      color: @brand_color;
    }
     
    h2 {
      color: @brand_color;
    }

    Here is the reference to the file in my master page:
    <link href="~/main.less" type="text/css" media="all" rel="stylesheet"/>

    Can you provide us more information? For example is there a request to the file in the console, is there an error when parsing, are there any styles applied?


    Regards,
    Jordan
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

  5. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    08 Sep 2011
    Link to this post
    Hey Jordan,
      Yeah you're correct, sorry I didn't make myself more clear :)

    ...try and have it auto-serve out of Global instead of linking in the header
  6. Jordan
    Jordan avatar
    172 posts
    Registered:
    20 Oct 2015
    08 Sep 2011
    Link to this post
    Hi Steve,

     
    As you know the Global folder is just for auto-load the CSS files of the theme and if you put the *.less files there they just won't load. You should link the file manually. 


    Best wishes,
    Jordan
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

  7. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    08 Sep 2011
    Link to this post
    Yep... I guess that was the initial request :)

    I want to use the auto-served folder...

    So I'm starting to remember the issue now...it doesn't seem to work in App_Themes (this was testing I did in like february)
    http://groups.google.com/group/dotless/browse_thread/thread/7fb0e1b42e38b7e6?pli=1

    So I tried in in SF in hopes that it would just work, but same deal
7 posts, 0 answered