More in this section
Forums / General Discussions / System.Net.Mail.SmtpException: Server does not support secure connections.

System.Net.Mail.SmtpException: Server does not support secure connections.

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
2 posts, 0 answered
  1. Sarlin
    Sarlin avatar
    1 posts
    Registered:
    26 Nov 2012
    12 Jun 2014
    Link to this post

    I am getting an exception " System.Net.Mail.SmtpException:: Server does not support secure 

    connections." when I try sending emails using office365.

    Under Administration >> Settings >> Advance >> System>> SMTP, I populated the following settings:

    host: smtp.office365.com
    Port: 587
    Username: xxxxx@xxxxx.com
    Password: xxxxxxx
    DeliveryMethod: Network
    EnableSSL: [ Checked ]
    Timeout: 10000
    DefaultSenderEmailAddress: xxxxx@xxx.com
    EmailSubjectEncoding: uft-8 
    EmailBodyEncoding: utf-8

    I am not sure why I am having this problem. It works in my local machine but it 

    doesn't work in production or my build environment.

    Any ideas why I am having this problem?

    Thank you for your time, 

    Sarlin

  2. Daniel Plomp
    Daniel Plomp avatar
    952 posts
    Registered:
    18 Feb 2004
    13 Jun 2014 in reply to Sarlin
    Link to this post

    Hi Sarlin,

    I think you need to change your port to 465, since you are using SSL. I'm using port 587 together with TLS, but I don't think that protocol is supported inside these SMTP parameters.

    Kind regards,
    Daniel

2 posts, 0 answered