More in this section

Forums / General Discussions / Telerik.Web.UI

Telerik.Web.UI

4 posts, 0 answered
  1. Med
    Med avatar
    22 posts
    Registered:
    19 Mar 2012
    20 Mar 2012
    Link to this post
    Hello,
    I have upgrade my sitefinity from 4.4 to 5,I have created a project and I have got this error :

    Could not load file or assembly 'Telerik.Web.UI, Version=2011.3.1115.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

    Exception Details: System.IO.FileLoadException: Could not load file or assembly 'Telerik.Web.UI, Version=2011.3.1115.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

    Source Error: 

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'Telerik.Web.UI, Version=2011.3.1115.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4' could not be loaded.

    AVT : la journalisation de liaison d'assembly est désactivée.
    Pour activer la journalisation des échecs de liaison d'assembly, attribuez la valeur 1 à la valeur de Registre [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD).
    Remarque : une certaine perte de performance est associée à l'enregistrement dans le journal des échecs de liaison d'assembly.
    Pour désactiver cette fonctionnalité, supprimez la valeur de Registre [HKLM\Software\Microsoft\Fusion!EnableLog].

    I dont know why !
    Thanks 
  2. Med
    Med avatar
    22 posts
    Registered:
    19 Mar 2012
    20 Mar 2012
    Link to this post
    Hello,
    I resolved the problem by remplaced the actual Telerik.Web.UI by an other one ( version : 2011.3.1115.40)
    Hope that will be useful for some one ;)
    Thanks


  3. Berrabah
    Berrabah avatar
    25 posts
    Registered:
    12 Feb 2012
    20 Mar 2012
    Link to this post
    Hi Med,
    Thanks for the information,I had the same probleme befor.
    Thank you again
  4. Dan Sorensen
    Dan Sorensen avatar
    256 posts
    Registered:
    13 Aug 2010
    22 Mar 2012
    Link to this post
    Assembly Binding as explained by Sitefinity Steve's Blog post may solve that issue without having to replace dll files with older versions.
4 posts, 0 answered