More in this section

Forums / General Discussions / User complaint

User complaint

11 posts, 0 answered
  1. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    31 Aug 2010
    Link to this post
    I'm trying to sell someone on SF4, and they are currently 3.2 users...

    They are really a little gunshy about going the SF route again after 3.2.   Their issues mostly seem to be twofold

    1) Need to go back to developers to make new templates (so SF4 takes care of this)
    2) The RadEditor doesn't function as it should

    They were only partially happy with a trial-run of the beta due (still) to issue #2.

    Can I assure them the issues outlined in the RadEditor thread will be fixed for release? (I know it's not the sitefinity guys having to fix it...).  The RadEditor is frustrating for me to use, and I know HTML so I can understand a user who doesnt know why something is happening
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    31 Aug 2010
    Link to this post
    Hello Steve,

    Could you specify the issues that they have here so we could see how can help and address them. RadEditor is editable IFrame and it works similar ( some different features) way as all other text editors on the market.

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    31 Aug 2010
    Link to this post
    Pretty much everything covered here and most of those still happen with the latest release.  The beta did ship with an older version...so I can't say if all their issues were related to that version of the editor.

    Like you can somehow have a <h3> that gets a <p> embedded in it (still), then you cant get out so the entire content is being wrapped in the h3...so the only way to fix is dump back to html mode...but UserX wouldnt be able to understand how to do that.

    The exact feedback was

    "hyperlinks not working, buggy windows popping up, formatting is not intuitive -  a little crude, clunky, and not that intuitive."


    So most of that is due to beta obviously (like links not working), but in my previous talks with them the RadEditor was a big issue...not WYSIWYG, more like WhatYouWantHasBeenGimpedByTheEditor (WYWHBGBTE). 
  4. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    01 Sep 2010
    Link to this post
    Hello Steve,

    Regarding the issue with the editor it seems that it has been resolved - at least I cannot reproduce it on the on the online demo page of the RadEditor when I set it to handle new lines as paragraphs. I have tried using IE 8 and FF 3.6.8 and latest version Chrome. The RadControls for ASP.NET Ajax are going to be upgraded to match the latest official release - for now it is Q2 SP1, so this issue should be resolved once we upgrade the controls.

    Regards,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    01 Sep 2010
    Link to this post
    Have a quick look at this (FF 3.6)

    Should illustrate a bit of the frustration....but yeah, the paragraphs in the headers looks fixed :D
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    01 Sep 2010
    Link to this post
    Hello Steve,

    I do not see any paragraphs inserted in the <h3> tag in your video. In the demo  you use, you have set  NewLineBr = false; which means paragraphs are added when you press enter. If the property is true <br> tags are added. Here is the description of the NewLineBr property and how it works. I believe that this explains why you see these tags.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    01 Sep 2010
    Link to this post
    Right, no paragraphs in the header, that's what I meant, that seems to be fixed...

    However I DO have NewLineBr=False on purpose....I set it that way to show you

    Watch the video:
    15 seconds in I press enter. 
    Desired functionality: cursor sits inside a new paragraph...
    What Actually Happened: Editor created <br/><p></p> so it appears that I've gotten two lines when I only wanted one.

    Here's another

    So what I expect to happen when I hit Enter off of the Header is to be thrown into a paragraph to start entering the text (as paragraphs might have margins or some other style applied).  However it doesn't get wrapped in that paragraph until I hit enter again after typing it.
  8. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    06 Sep 2010
    Link to this post
    Hello Steve,

    This is the default behavior of the editor - it wraps text into <p></p> tags only after there is a new paragraph introduced. It would be best if you submit a feature request for the RadEditor explaining how the editor should handle new paragraphs.

    All the best,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  9. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    08 Sep 2010
    Link to this post
    Good news,
     
    The editor guys were able to re-produce and they're adding it to PITS (sadly as not scheduled)...but still...it's there
  10. Vassil
    Vassil avatar
    8 posts
    Registered:
    21 Apr 2003
    10 Sep 2010
    Link to this post
    The issue(s) might appear with a status of "unscheduled" but rumor has it that most, if not all, of the issues you reported will be fixed in the upcoming service pack of RadControls. This means that for the RC/official release you should not experience such problems when editing content.
  11. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    10 Sep 2010
    Link to this post
    Awesome :)

    I've got 3 test sites going for potential clients, they're going to be so happy
11 posts, 0 answered