More in this section

Forums / General Discussions / why is 4.0 using 2010.1.309.35 instead of 2010.2 713 of the radcontrols?

why is 4.0 using 2010.1.309.35 instead of 2010.2 713 of the radcontrols?

6 posts, 0 answered
  1. John
    John avatar
    5 posts
    Registered:
    23 Sep 2008
    08 Aug 2010
    Link to this post
    I have downloaded the sitefinity 4.o beta and it seems to be four versions behind of the radcontrols.
  2. John
    John avatar
    5 posts
    Registered:
    23 Sep 2008
    08 Aug 2010
    Link to this post
     

    Server Error in '/' Application.

    Could not load file or assembly 'Telerik.Web.UI, Version=2010.1.309.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.IO.FileLoadException: Could not load file or assembly 'Telerik.Web.UI, Version=2010.1.309.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'Telerik.Web.UI, Version=2010.1.309.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4' could not be loaded.

    === Pre-bind state information ===
    LOG: User = jmeek-PC\jmeek
    LOG: DisplayName = Telerik.Web.UI, Version=2010.1.309.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4
     (Fully-specified)
    LOG: Appbase = file:///C:/Program Files (x86)/Telerik/Projects/Access404/
    LOG: Initial PrivatePath = C:\Program Files (x86)\Telerik\Projects\Access404\bin
    Calling assembly : Telerik.Sitefinity, Version=4.0.565.0, Culture=neutral, PublicKeyToken=b28c218413bdf563.
    ===
    LOG: This bind starts in default load context.
    LOG: Using application configuration file: C:\Program Files (x86)\Telerik\Projects\Access404\web.config
    LOG: Using machine configuration file from C:\Windows\Microsoft.NET\Framework\v2.0.50727\config\machine.config.
    LOG: Post-policy reference: Telerik.Web.UI, Version=2010.1.309.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4
    LOG: Attempting download of new URL file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/Temporary ASP.NET Files/root/95c529a9/cf258303/Telerik.Web.UI.DLL.
    LOG: Attempting download of new URL file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/Temporary ASP.NET Files/root/95c529a9/cf258303/Telerik.Web.UI/Telerik.Web.UI.DLL.
    LOG: Attempting download of new URL file:///C:/Program Files (x86)/Telerik/Projects/Access404/bin/Telerik.Web.UI.DLL.
    WRN: Comparing the assembly name resulted in the mismatch: Minor Version
    ERR: Failed to complete setup of assembly (hr = 0x80131040). Probing terminated
  3. John
    John avatar
    5 posts
    Registered:
    23 Sep 2008
    08 Aug 2010
    Link to this post
    I tried installing version 2010.1.309.35 but the installer will not allow me to do since I have a newer verion on my system. I tried runing the upgrader and it still pointing to the 2010.1.309.35 version.
  4. mattc
    mattc avatar
    105 posts
    Registered:
    11 Aug 2007
    10 Aug 2010
    Link to this post
    Hi John

    When you create a project using the Manager it will create a folder called _EmptyProject in the same location.
    The /bin subfolder contains all the relevant files and DLLs (Sitefinity, OpenAccess, RadControls etc) that are required.

    Matt
  5. Kurt
    Kurt avatar
    7 posts
    Registered:
    31 Aug 2006
    13 Aug 2010
    Link to this post
    I had this same problem. I do have the latest version of the Telerik Rad Controls installed,  and opening the project in Visual Studio seemed to cause the Web.UI dill to be automatically updated. I had to remove, then re- add the .dll reference to resolve this issue.
  6. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    16 Aug 2010
    Link to this post
    Hi,

    Thank you for the follow up. I guess, we missed that in the hurry. We will try to be more strict about the updates of the RadControls in the beta and pre-release versions of the application.

    Sorry for the inconvenience. 

    Best wishes,
    Georgi
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
6 posts, 0 answered