More in this section

Forums / General Discussions / Breadcrumbs no longer working

Breadcrumbs no longer working

11 posts, 0 answered
  1. WebGeek
    WebGeek avatar
    186 posts
    Registered:
    20 Dec 2006
    22 May 2007
    Link to this post
    I am not sure what changed, but since I upgraded to the final version my breadcrumbs no longer work.

    Any advice will be appreciated.
  2. Pepi
    Pepi avatar
    981 posts
    Registered:
    31 Jan 2017
    23 May 2007
    Link to this post
    Hello james,
     
    We could not reproduce such a behavior. Probably, the problem with breadcrumbs is caused by the upgrade to the final version. So could you please send us your project and database so we can check?
    Please open a new support thread and attach the upgraded project and database there?

    Looking forward to your reply,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. WebGeek
    WebGeek avatar
    186 posts
    Registered:
    20 Dec 2006
    23 May 2007
    Link to this post
    When I created a new page yesterday the breadcrumbs worked on those, but it still does not work on all of the pages that I created using RC2.  If I try to reattach a breadcrumb to one of the pages that I created with RC2 I get the following error - Unknown Server Tag cc1:Breadcrumb.
  4. Pepi
    Pepi avatar
    981 posts
    Registered:
    31 Jan 2017
    23 May 2007
    Link to this post
    Hello James,

    Could you please try to publish the page, containing the breadcrumb in spite of this error? According to us everything should work properly. If there is any problem, I will ask you to send us the project and database.

    Kind regards,

    Author nickname
    the Telerik team


    Instantly find answers to your questions at the new Telerik Support Center
  5. WebGeek
    WebGeek avatar
    186 posts
    Registered:
    20 Dec 2006
    23 May 2007
    Link to this post
    Did anything change regarding where the breadcrumb componet is located in the structure of sitefinity?  Maybe it can not see the file that it is looking for.
  6. Bob
    Bob avatar
    330 posts
    Registered:
    30 Dec 2016
    23 May 2007
    Link to this post
    Sorry James, we should have thought about it earlier. Indeed, the namespace and assembly have changed to avoid future conflicts with Prometheus project. The new declaration should be:

    Telerik.Cms.Web.UI.Breadcrumb, Telerik.Cms.Web.UI

    Best wishes,
    Bob
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  7. WebGeek
    WebGeek avatar
    186 posts
    Registered:
    20 Dec 2006
    23 May 2007
    Link to this post
    Where should I change it? Do I need to change it in the Web.config file?
  8. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    23 May 2007
    Link to this post
    Hi James,

    Please check if after the upgrade you have this declaration in the web.config file:
    <toolboxControls>
    <clear />
    ...
    <add name="Breadcrumb" section="Navigation" type="Telerik.Cms.Web.UI.Breadcrumb, Telerik.Cms.Web.UI" />
    If it is not exactly the same, you need to go through all pages using breadcrumbs and replace with the new breadcrumb control.

    Sincerely yours,
    Rebecca
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  9. WebGeek
    WebGeek avatar
    186 posts
    Registered:
    20 Dec 2006
    23 May 2007
    Link to this post
    It looked like yours.  I will try replacing them in my template.
  10. WebGeek
    WebGeek avatar
    186 posts
    Registered:
    20 Dec 2006
    23 May 2007
    Link to this post
    I have found a solution that will work - but I thought I would provide it to you so that you might be able to tell me a faster away to approach it.

    If I recreate the Page Group page and then drag and drop my files out of the old page group and into the new page group the breadcrumbs will work for all of my pages under that Page Group. 

    I do not mind doing this since I only have about 40 page groups, but if you have a faster way of doing things, please let me know.
  11. Vassil Daskalov
    Vassil Daskalov avatar
    261 posts
    Registered:
    18 May 2013
    24 May 2007
    Link to this post
    Hello James,

    It is nice you have found a solution for your problem, though I don't quite understand it. You are saying that you drag and drop "files" to the page group. Perhaps you mean controls?

    Anyway, I think there is a faster way to achieve these though it is less reliable. You could directly change the type of the control in the database. All you need to do is run this script:

    USE yourDb

    UPDATE sf_WebControlBase
    SET type = 'Telerik.Cms.Web.UI.Breadcrumb, Telerik.Cms.Web.UI'
    WHERE type = 'Telerik.Web.UI.Breadcrumb, Telerik.Web.UI'

    Please backup the database in case something gets messed up. Hope this fixes your problem faster. Let me know how it goes.

    Kind regards,
    Vassil Daskalov
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Register for webinar
11 posts, 0 answered