More in this section
Forums / General Discussions / Incorrect hyperlinks on Tag page numbers

Incorrect hyperlinks on Tag page numbers

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
2 posts, 0 answered
  1. Neil
    Neil avatar
    26 posts
    Registered:
    03 Aug 2011
    23 Jul 2013
    Link to this post
    Our website has several blog posts and there are multiple tags associated with each post.  We have added the Tags control to all page templates so that the tags appear on every page of the site and have set the BaseUrl of the control to "~/home/all-tags" (without the quotes).

    Each tag correctly links off to its own page, for example, https://ourwebsite/home/all-tags/-in-Tags/Tags/TagsType1 and as there are multiple blogs per tag they are split over several pages and there are links to these additional pages at the bottom.

    The problem is that the page number links are wrong.  In the case of the above example URL, page 2's link should be  https://ourwebsite/home/all-tags/-in-Tags/Tags/TagsType1/page/2/ , but instead it is  https://ourwebsite/home/page/2/, which goes to the 2nd page of all the tags and it's the same for all pages.

    Is there another setting I need to configure so that the page links stay with the current tag or is this a bug?

    Thanks in advance.
  2. Neil
    Neil avatar
    26 posts
    Registered:
    03 Aug 2011
2 posts, 0 answered