More in this section
Forums / General Discussions / Need help with preventing <system.webServer> inheritance

Need help with preventing &lt;system.webServer&gt; inheritance

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
2 posts, 0 answered
  1. JOHN STRUCHYNSKI
    JOHN STRUCHYNSKI avatar
    14 posts
    Registered:
    30 May 2008
    18 Jul 2012
    Link to this post
    Hi,

    We are moving our web site collection to a new server.
    Our root site (domain.com) is a Sitefinity 3.7 (SP4) website. We also have several sub applications configured as virtual directories with their own designated application pools.

    Our Sitefinity 3.7 install is configured to use a ASP.NET 4.0 application pool. Our sub sites need to run ASP.NET 2.0 application pools.

    My problem is that when i try to stop web.config inheritance of <system.webServer> in the root site (Sitefinity) using the following approach:
    1.<location path="." inheritInChildApplications="false">
    2.  <system.webServer>
    3.    <validation validateIntegratedModeConfiguration="false"/>
    4.    <!-- Setting here -->
    5.  </system.webServer>
    6.</location>

    I get the following error message:

    '~/Telerik.Web.UI.WebResource.axd' is missing in web.config. RadScriptManager requires a HttpHandler registration in web.config. Please, use the control Smart Tag to add the handler automatically, or see the help for more information: Controls > RadScriptManager


    Is there some way to solve this issue?
    I want the sub sites to be independent of the root Sitefinity site.

    Thanks,

    Ole
  2. JOHN STRUCHYNSKI
    JOHN STRUCHYNSKI avatar
    14 posts
    Registered:
    30 May 2008
    18 Jul 2012
    Link to this post
    In case somebody else has the same problem I found this solution:

    Running a Classic 4.0 Application pool and...

    http://frejnorling.wordpress.com/2011/02/13/configure-iis-7-5-to-manage-asp-net-4-0-web-pages/
2 posts, 0 answered