More in this section

Forums / Module Builder / Can't add contents to Modules created by another user

Can't add contents to Modules created by another user

4 posts, 1 answered
  1. Anil
    Anil avatar
    6 posts
    24 Sep 2013
    06 Mar 2014
    Link to this post


    We have created a custom module for extending the 'News'  using Module Builder. But the system is not allowing to add contents by other users. (Its working fine for the user who created it)

    Please see the error message below  from the log file.




    Timestamp: 3/6/2014 3:40:35 PM

    Message: HandlingInstanceID: 6fa75169-ed3c-47ce-b18c-42abec83ea98
    An exception of type 'System.NullReferenceException' occurred and was caught.
    03/06/2014 15:40:35
    Type : System.NullReferenceException, mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089
    Message : Object reference not set to an instance of an object.
    Source : Telerik.Sitefinity
    Help link : 
    Data : System.Collections.ListDictionaryInternal
    TargetSite : Telerik.Sitefinity.Web.UI.ContentUI.Contracts.IContentViewDefinition GetDefaultMasterView()
    HResult : -2147467261
    Stack Trace :    at Telerik.Sitefinity.Web.UI.ContentUI.ContentViewControlDefinition.GetDefaultMasterView()
       at Telerik.Sitefinity.Web.UI.ContentUI.ContentView.DetermineCurrentViewName()
       at Telerik.Sitefinity.Web.UI.ContentUI.ContentView.CreateChildControls()
       at System.Web.UI.Control.EnsureChildControls()
       at System.Web.UI.Control.PreRenderRecursiveInternal()
       at System.Web.UI.Control.PreRenderRecursiveInternal()
       at System.Web.UI.Control.PreRenderRecursiveInternal()
       at System.Web.UI.Control.PreRenderRecursiveInternal()
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    Additional Info:

    MachineName : W7DEV7GWTKQ1
    TimeStamp : 3/6/2014 3:40:35 PM
    FullName : Telerik.Sitefinity.Utilities, Version=6.3.5000.0, Culture=neutral, PublicKeyToken=b28c218413bdf563
    AppDomainName : /LM/W3SVC/5/ROOT-9-130385930128078830
    ThreadIdentity : admin
    Requested URL :

    Category: ErrorLog

    Priority: 0

    EventId: 90000

    Severity: Error

    Title:Enterprise Library Exception Handling

    Machine: W7DEV7GWTKQ1

    App Domain: /LM/W3SVC/5/ROOT-9-130385930128078830

    ProcessId: 9368

    Process Name: c:\windows\system32\inetsrv\w3wp.exe

    Thread Name: 

    Win32 ThreadId:8756

    Extended Properties: 


  2. Vassil Vassilev
     Vassil Vassilev avatar
    308 posts
    21 Jan 2015
    07 Mar 2014
    Link to this post
    Hello Anil,

    I'm sorry to hear about the issues you're experiencing with your custom modules.

    Can you confirm that configuration files have not been modified (under App_Data/Sitefinity/Configuration) either manually or by changing a setting under the Administration backend section, the web.config has been changed, or some of the values in the DB have been modified manually.
    In order to make sure we're giving you the best advice we'll need to collect some additional information, namely:
    1. Which Sitefinity version you are using?
    2. Have you performed an upgrade and can you reproduce this on a brand new project as it is very important to isolate the source of your problem (if you can reproduce this on a brand new project, please provide us the steps)?
    3. Did the module worked at some point?

    Looking forwards to your response.

    Vassil Vassilev
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
  3. Anil
    Anil avatar
    6 posts
    24 Sep 2013
    11 Mar 2014 in reply to Vassil Vassilev
    Link to this post

    Hi Vassil Vassilev,

     We solved the issue and it was with configuration file.





  4. Joe
    Joe avatar
    21 posts
    01 Dec 2010
    16 May 2014
    Link to this post

    Can you please post what you fixed in the config file to solve this issue as I am experiencing the same issue?

4 posts, 1 answered