More in this section
Forums / Module Builder / Sitefinity stops working after I try to activate a dynamic module

Sitefinity stops working after I try to activate a dynamic module

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
1 posts, 0 answered
  1. pallav
    pallav avatar
    0 posts
    Registered:
    25 Mar 2017
    25 Mar 2017
    Link to this post

    I am trying to create a new dynamic module using Sitefinity V 7.1. Everything seems fine until I try to activate the newly created module.  Once I click on activate module button, sitefinity stops working. We get the followig error

    [OpenAccessException: SQL exception on '-- System.Guid[] Telerik.Sitefinity.DynamicTypes.Model.WebsiteBasicsItems.Websitebasicsitem.Roles
    CREATE TABLE [wbstbscstms_wbstbscsitem_roles] (
        [base_id] uniqueidentifier NOT NULL,
        [seq] int NOT NULL,                     -- <sequence>
        [val] uniqueidentifier NULL,            -- <value>
        CONSTRAINT [pk_wbstbscstms_wbstbs_28E1D130] PRIMARY KEY ([base_id], [seq])
    )' : Subquery returned more than 1 value. This is not permitted when the subquery follows =, !=, <, <= , >, >= or when the subquery is used as an expression.
    The statement has been terminated.]

     

    Any idea what going wrong and how can I fix this issue.

    Thanks,

    Pallav

     

     

1 posts, 0 answered