More in this section
Forums / Module Builder / Unable to retrieve the dynamic module data using sitefinity api after addon installation.

Unable to retrieve the dynamic module data using sitefinity api after addon installation.

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
1 posts, 0 answered
  1. Ramesh
    Ramesh avatar
    0 posts
    Registered:
    24 May 2016
    10 Feb 2017
    Link to this post

    Hi,

    We have developed the addon using dynamic  module and successfully working in my local machine but if we importing in another machine not able to retrieving the module data. Below are the steps we have followed in addon development.

    Step1: Created module using sitefinity module builder and exported as addon. And created the package. followed this link(http://docs.sitefinity.com/export-the-add-on).

    Step2: In my local machine able to retrieve the data, when I added  My(Aadd-On) dll to Sitefinity empty Project  , but if i installed using  the  addon in  not able to retrieve the module data but module got installed successfully.

    find the below code lines for get the more details.

    void Retrieve()

    {

     var mgr = DynamicModuleManager.GetManager();

                    var typeName = TypeResolutionService.ResolveType("Telerik.Sitefinity.DynamicTypes.Model.SendSMS.SendSMSConfiguration");
                    DynamicContent twilioFormNames = (DynamicContent)mgr.GetDataItems(typeName)
                    .Where(string.Format("FormName.Contains(\"{0}\") && Status=\"Live\"",evt.FormTitle))
                    .FirstOrDefault();

    }

    Can you please help us to resolve the issue.

     

    Thanks,

    Ramesh Ch.

1 posts, 0 answered