More in this section

Forums / Set-up & Installation / Install / config problem creating initial site in 3.2

Install / config problem creating initial site in 3.2

8 posts, 0 answered
  1. Chris
    Chris avatar
    3 posts
    05 Mar 2008
    06 Mar 2008
    Link to this post
    I was informed about your CMS solution just yesterday and downloaded the community server 3.2 edition of the install to start working with.  I don't know if it is the install or something unique about my machine that causes me not to be able to effectively get a site started.  I have looked and reviewed most every posting that I could find on the forums related to install problems and none of them appear to address the issue that I am having.

    When I start the project manager and attempt to run the TIU site it fails to ever launch.  When I attempted to create my own first site everything appears to be going well until I "browse project" from the manager screen and it prompts me to setup my initial DB...  then I get this error.

    "There was an error trying to connect to the Database Server:
    Generating user instances in SQL Server is disabled. Use sp_configure 'user instances enabled' to generate user instances."

    I have uninstalled, re-installed, and gone through the whole works four times now. I can't seem to overcome this issue on my own, so I'm hear asking for some guidance.

    The configuration of my development computer that I am using is a notebook running XP Pro (non-domain), IIS 5.1, SQL Server 2005 Express Edition,  and I have both VS Express 2005 & 2008 editions on this computer as well. 

    Note: I have the five major releases of the .NET framework installed as well on this machine up to v3.5.

    Thanks in advance for any assistance.
  2. Chris
    Chris avatar
    3 posts
    05 Mar 2008
    06 Mar 2008
    Link to this post
    Some additional information to aid in troubleshooting.  From MS SQL Server Management Studio Express, when I attempt to attach to the .MDF file that is located in the "C:\Program Files\telerik\Sitefinity3.2 Community\WebSites\TIUSite_v3.2\App_Data" location, it points to a database file that should be located in the My Documents folder (which I don't have that file there).

    And in addition to that, when I attempt to connect to the database for my initial test site I see that the path that is being called out in SQL Manager as being "C:\DOCUMENTS AND SETTINGS\VASILEV\MY DOCUMENTS\SITEFINITY\SITEFINITY3.0\SITEFINITYWEB\APP_DATA\SITEFINITY.MDF"  That of course is not my computer nor user name. 

    Thought that may help to try and troubleshoot this issue.
  3. Pepi
    Pepi avatar
    981 posts
    31 Jan 2017
    07 Mar 2008
    Link to this post
    Hi Chris,

    'user instances enabled' is a server option of SQL Express. I would recommend you execute the following statement through SQL Server Management Studio Express:

    exec sp_configure 'user instances enabled', 1 

    This should solve the problem with "There was an error trying to connect ..." exception.

    Regarding your issue with attaching .mdf file, we need more information to localize what is wrong. Could you describe the exact steps for reproducing the described behavior?

    Thanks for your cooperation in advance.

    All the best,
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  4. Chris
    Chris avatar
    3 posts
    05 Mar 2008
    09 Mar 2008
    Link to this post
    Thanks for the information.  However, I broke down on installing the solution on this development box.  I was able to install the entire solution on a clean loaded machine.  Once I was able to get the application at least loading on that machine, I uninstalled SQL on this particular computer and Sitefinity.  Cleanly reloaded both applications and now it works fine.

    Thanks for the help.

  5. Paul Dain
    Paul Dain avatar
    7 posts
    15 Mar 2006
    19 Mar 2008
    Link to this post
    I'm encountering the same issue on Vista with IIS 7. When I create a new, blank project I encounter the following:

    1) In the project manager, it indicates that the site was successfully created. However, when I go administer the new site, I'm presented with a page that simply says "Thank you for visiting our web site. Please return soon for updates." Based on the install instructions, I was expecting to be able to configure the database connection (pages 26 and 27 of the InstallationGuide_3_2.pdf).

    2) If I browse to the project's "Sitefinity" directory to administer the site, I'm presented with the following runtime error: "An error has occurred while establishing a connection to the server.  When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified) "

    3) If I attempt to attach to the new project's Sitefinity.mdf located in App_Data, it cannot complete and I receive this error: "Directory lookup for the file "C:\Documents and Settings\vasilev\My Documents\Sitefinity\Sitefinity3.0\SitefinityWeb\App_Data\Sitefinity.mdf" failed with the operating system error 3(The system cannot find the path specified.). (Microsoft SQL Server, Error: 5133)"

    This directory does not exist on my local workstation, and I cannot change the path anywhere. Note that I am using SQL Server 2005 Developer Edition.

    Thank you for the assistance,

    - Paul
  6. Nikifor
    Nikifor avatar
    232 posts
    18 May 2013
    20 Mar 2008
    Link to this post
    Hi Paul Dain,

    Go to IIS -> Advanced Properties of the virtual directory created for your new project. Set Classic .NET AppPool for the Application Pool from the Behavior section. For detailed explanation, see the Installation Guide, Installing Sitefinity Under Windows Vista -> Configuring the Classic.NET AppPool section.

    As for the SQL connection error you have received - it seems that your database is not accessible from the machine you are working on. Please, check if the database is not Read-only. If it is a newly-created one , it may be without modify permissions.

    Another possibility is that you might not have enabled Remote access to the database.

    You could take a look at the following links for more detailed information on troubleshooting techniques: Link1 and Link2.

    Hope that the provided information is helpful. Please do not hesitate to contact us if you have any further questions.

    Kind regards,
    Nikifor Hristov
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  7. Dave
    Dave avatar
    5 posts
    14 May 2008
    19 Aug 2008
    Link to this post
    I too see the user folder "VASILEV" in an error message when trying to connect to a database.
    Obviously, there is someone at Telerik with that username in the system that worked on this product; and somehow hard coded their information into part of the code.
    Please find this and correct it!!!

  8. Georgi
    Georgi avatar
    3583 posts
    28 Oct 2016
    20 Aug 2008
    Link to this post
    Hello Dave,

    This information is not hardcoded in the code. This is stored in the database when it is created. We created the empty database for you, so you could use it without any efforts on creating a database. If you for example create an SQLexpress database, your windows username will be stored inside too. If you then migrate the project to some other host and receive the same error, you will see your path and username in the error log.
    Having that said, this could not fixed.

    You could delete the empty database anytime, and create a new one if this message bothers you, but let me once again remind that the database was created for your convenience.

    One more thing - we at Telerik are always glad to receive any constructive feedback. If the previous post does not help you to resolve the problem, please give us some more details on the circumstances in which you get the error, and we will give our best to assist you.

    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Register for webinar
8 posts, 0 answered