+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / 5.3 GroupPage with only RedirecPages not showing in navigation

5.3 GroupPage with only RedirecPages not showing in navigation

10 posts, 0 answered
  1. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    21 Jan 2013
    Link to this post
    I know a group page is looking for its first 'real' page in it.

    But think about this.

    MySite  has a Main Navigation Group Page called 'Link' and two redirect pages one to 'http://www.Telerik.com' the other one to 'http://www.sitefinity.com'

    I only wished they would show up in the navigation.

    As soon as I add any other real page the redirect will show. 

    I simply think thats bad design, and in no way clear to a client.

    http://www.marktold.com/screencast/sf_group_page_redirect_links.swf

    I think group pages never really worked as a customer administrating would expect. But this is simply another example how an easy task simply can not be simply done!

    Markus

    PS: Just getting annoyed once more about this and try to have Telerik review its position on GroupPages.
  2. Stefani Tacheva
    Stefani Tacheva avatar
    718 posts
    Registered:
    06 Dec 2016
    24 Jan 2013
    Link to this post
    Hello Markus,

    This is a bug in Sitefinity and we have this bug logged in our system. You could follow its status in PITS on the following URL.

    I hope that we will be able to fix this problem soon.

    Regards,
    Stefani Tacheva
    the Telerik team
  3. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    24 Jan 2013 in reply to Stefani Tacheva
    Link to this post
    Dear Stefani

    Sorry. But I don't you to hope for it to be fixed. I want Telerik to make Sitefinity work as expected. And this is a major but - PAGES NOT SHOWING IN NAVIGATION.

    This problem was reported first on Sept 18th- http://www.sitefinity.com/developer-network/forums/bugs-issues-/groups-with-redirect-pages-does-not-show-in-menu

    PITS shows entry on 24th Oct 12  so the issue will be 4 month old by the time 5.4 is released!!!!

    Fix did not seem to make it into 5.2.3700,  5.2.3800 nor 5.3.3900 after the bug was reported. Not very satisfying!!!

    Group pages have been troubling me for quite some time but this is the worst bug so far.

    Get someone from Development commit to fixing this in 5.4 since there won't be a hotfix for 5.3 for other issues.

    Markus
  4. Stefani Tacheva
    Stefani Tacheva avatar
    718 posts
    Registered:
    06 Dec 2016
    29 Jan 2013
    Link to this post
    Hello Markus,

    Please accept my apologies for the inconvenience.

    I have talked to our UX team and this is indeed a serious bug. What I have done:
    1. I have increased the bug priority and severity.
    2. Then I have discussed the problem with a team that will be working on fixing this bug.

    We will do our best to integrate the fix as soon as possible.

    Thank you for the understanding and excuse me again.

    Kind regards,
    Stefani Tacheva
    the Telerik team
  5. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    29 Jan 2013 in reply to Stefani Tacheva
    Link to this post
    Dear Stefani

    Thank's a lot. And I will do my best not to be hugely disappointed if this is still not fixed in 5.4. The whole PageGroup mess has been around for a long time and there should be still two weeks time for getting someone to fix such a bad bug for the next 5.4 release.

    At the moment I still keep my hope up that you can deliver what I (and probably other) are expecting. 

    Markus
  6. Laura
    Laura avatar
    311 posts
    Registered:
    25 Feb 2008
    29 Jan 2013 in reply to Markus
    Link to this post
    I am trying to hack my way through this one as we speak!  1 VOTE from me!!!
  7. Stefani Tacheva
    Stefani Tacheva avatar
    718 posts
    Registered:
    06 Dec 2016
    30 Jan 2013
    Link to this post
    Hello,

    Our developers have stared investigating where the problem comes from. I hope that the fix will be delivered with Sitefinity 5.4. I will inform you if there is new information connected to the issue.

    Kind regards,
    Stefani Tacheva
    the Telerik team
  8. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
  9. Laura
    Laura avatar
    311 posts
    Registered:
    25 Feb 2008
    30 Jan 2013 in reply to Markus
    Link to this post
    @Markus
    YES!  That was what i meant by 1 VOTE from me. :-)

    By the way we just made it redirect in server side code. Not ideal of course.
  10. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    31 Jan 2013 in reply to Laura
    Link to this post
    Dear Stefani

    I am glad to hear that the team at least started to look at the problem. That's a beginning.

    Sure hope this and other bugs will be fixed in 5.4

    Markus
10 posts, 0 answered