Try Now
More in this section

Forums / Bugs & Issues / 6.1 link manager HTML view: was not found

6.1 link manager HTML view: was not found

2 posts, 0 answered
  1. Markus
    Markus avatar
    2763 posts
    25 Nov 2005
    16 Aug 2013
    Link to this post
    www.marktold.com/screencast/sf_link_not_found.swf shwos what I am talking about.

    Link online works and looks fine. Just wondering why this code is produced.


    <a href="Item with ID: '2b23c219-ffad-688c-ad43-ff00005a936a' was not found!" sfref="[f669d9a7-009d-4d83-ddaa-000000000002]2b23c219-ffad-688c-ad43-ff00005a936a">Impressum</a>

  2. Jen Peleva
    Jen Peleva avatar
    568 posts
    10 Sep 2016
    21 Aug 2013
    Link to this post
    Hello Markus,

     It seems that for some reason the DynamicLinkParser wasn't able to return the url of the page you have chosen. This can happen if the key, which in your case is '[f669d9a7-009d-4d83-ddaa-000000000002
    ' is null (this is the id of the Pages node) or if the url of the chosen page could not be resolved. You can check in the database and make sure in sf_page_node that you have a record for both ids - 'f669d9a7-009d-4d83-ddaa-000000000002' and '2b23c219-ffad-688c-ad43-ff00005a936a'. The second one is the id of the chosen page. To be sure why exactly its url could ot be resolved, I need to attach the project to the source. But since you mentioned that the link functions properly, I suppose this wouldn't be needed. If you experience similar issues, please open a support ticket, where we'll be able to investigate this behavior further.

    Jen Peleva
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered