+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / 6.2 Inline Editing

6.2 Inline Editing

6 posts, 0 answered
  1. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    17 Oct 2013
    Link to this post
    I gotta say, on a live project while the inline editing is nice, I find it AMAZINGLY laggy in that when I click something I as a developer know maybe something is happening in the background so I'll wait, however a user will think nothing happened.

    Even like clicking publish there's zero loading icons telling me it's working
  2. Kristian Smilenov
    Kristian Smilenov avatar
    32 posts
    Registered:
    18 Mar 2015
    18 Oct 2013
    Link to this post
    Hi Steve,

    I am very sorry to hear that, can you give me some more details of what is the actual case. Is this slow behaviour only the first time you enable Inline Editing or try to edit field?

    I have made screenshots to show you that we have loadings when you try to edit a field or publish some changes.

    If the loading indicators are missing on your side, there may be some css conflicts and we will need your project for further investigation. 

    Regards,
    Kristian Smilenov
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    21 Oct 2013 in reply to Steve
    Link to this post
    Anyway for me it seems it's the call to this service:
    "/RestApi/Sitefinity/inlineediting/temp/0fb24028-892a-6afc-a007-ff0000973b9b/?provider=&itemType=Telerik.Sitefinity.Pages.Model.PageDraftControl&_=1382364112191"

    The lag time is anywhere from 1-5 seconds so you click in an editable area and then it just seems like nothing is happening...there's no loading icon that ANYTHING is happening.
  4. Kristian Smilenov
    Kristian Smilenov avatar
    32 posts
    Registered:
    18 Mar 2015
    22 Oct 2013
    Link to this post
    Hi Steve,

    This call is made the first time you click to edit page control (Content block, Image control ...)
    Can you check if the same problem exists if you click to edit News Item for example? Another thing - are you experiencing the same issue on your dev environment? 

    Regards,
    Kristian Smilenov
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    22 Oct 2013 in reply to Kristian Smilenov
    Link to this post
    This is the dev environment
    Core i7, 16 gigs of ram, 256g revo harddrive
    ...it's a powerful machine

    Images seems okay...kinda: http://screencast.com/t/Gsq4oASDA

    So seems to be the first call to the services that lag...can you guys maybe make a dummy stub to hit to prime it a bit on load of inline edit?
  6. Kristian Smilenov
    Kristian Smilenov avatar
    32 posts
    Registered:
    18 Mar 2015
    23 Oct 2013
    Link to this post
    Hello Steve,

    You are getting the error message on the video because after refresh of the page with (../Action/InEdit in the url) Inline Editing mode is enabled and not yet fully loaded when you click exit editing.

    The problem with the first time you click page control is that the whole page is checked out for edit, meaning that it doesn't matter if you click a content block or image control for the first time. Once checked-out each time you edit the controls they will load fast. 

    We are doing this the first time page control is edited, because you may never actually get to edit one, and checking out the page when Inline Editing mode is enabled will be pointless as you may be editing content items only, so I may say that this is by design what is happening.  

    PS: The first call to the service is made to "/RestApi/Sitefinity/inlineediting/configuration", and is made when you enable Inline Editing.

    Regards,

    Kristian Smilenov
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
6 posts, 0 answered