+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / 7.0 blog details error when allowing comments

7.0 blog details error when allowing comments

8 posts, 0 answered
  1. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    11 Apr 2014
    Link to this post

    I upgraded a site from 6.3 to 7.0.

    Now when I allow comments on blog post I get the attached error.

     After upgrading I only uploaded the dlls in bin. Anything else that might had to be uploaded?

     Markus

  2. Daniel Plomp
    Daniel Plomp avatar
    952 posts
    Registered:
    18 Feb 2004
    11 Apr 2014 in reply to Markus
    Link to this post

    Hi Markus,

    Did you make adjustments to the Comments control or still using the old BlogPost Comments?

    Daniel

  3. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    11 Apr 2014 in reply to Daniel Plomp
    Link to this post

    I did nothting special as far as I know. Simply upgraded from 6.3 to 7.0.

    Maybe I need to check my templates if I have removed the comments block for example or so?

    -> Old BlogPost Comments?

     Markus

  4. Vlad
    Vlad avatar
    498 posts
    Registered:
    15 Jul 2016
    14 Apr 2014
    Link to this post
    Hi Markus,

    Seems you have modified "Comments submit form" (Design -> Widget Templates -> Comments submit form). This template has a breaking change in 7.0. I have attached the original template and the changes compared to the 6.3 version.
    You can also "Restore template to default", in case you want to ingnore your changes, or just to see the original template.

    We are sorry for the inconvenience.

    Regards,
    Vlad
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  5. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    14 Apr 2014 in reply to Vlad
    Link to this post

    Dear Vlad

    Resetting the comments submit form widget worked. I don't remember having it changed which leads me to another question

    When and how do widgets get updated when you update from 6.3 to 7.0 for example?

     Markus

  6. Vlad
    Vlad avatar
    498 posts
    Registered:
    15 Jul 2016
    15 Apr 2014
    Link to this post
    Hi Markus,

    Currently, the widget templates are not updated on upgrade, as we don't have a mechanism for merging templates.
    Ones you update a widget template, it is persisted in the database and used instead of the default one. Any change in the default template, coming with the newer version, does not affect the persisted customized template, which in some cases is expected behavior. We know that, in other cases, this could cause some issues with missing functionality on customized templates (excluding the case with the error reported in this thread - it is a bug), and we will try to address this in the future.
    Maybe you have changed this template in the past, otherwise it should not be persisted.

    Regards,
    Vlad
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  7. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    15 Apr 2014 in reply to Vlad
    Link to this post

    Dear Vlad

    I am very much OK with Sitefnity not updating my widget templates (for once its not a bug to me - seldom enough)

    -->  I was asking how and when the default widget templates get updated.

    Markus

     

    Where are such breaking changes documented? 

    I think it should be documented somewhere not? Did not find it in any of these documents or did not look in db or api changes since I did not use either on in this case.

    http://www.sitefinity.com/product/version-notes/sitefinity-7.0
    http://www.sitefinity.com/documentation/documentationarticles/database-changes-between-6.3-and-7.0

    http://www.sitefinity.com/documentation/documentationarticles/api-changes-in-sitefinity-7.0

     

  8. Vlad
    Vlad avatar
    498 posts
    Registered:
    15 Jul 2016
    15 Apr 2014
    Link to this post
    Hello Markus,

    The default templates are stored as embedded resources in the Sitefinity assemblies. They are updated when you replace the Sitefinity DLLs in your bin folder.
    Unfortunately, such documentation is missing for now. We will address this issue for the next releases.

    Regards,
    Vlad
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
8 posts, 0 answered