1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Broken Links after moving page group and image renaming problems

Broken Links after moving page group and image renaming problems

3 posts, 0 answered
  1. Scott Rozman
    Scott Rozman avatar
    93 posts
    Registered:
    10 Oct 2012
    07 Dec 2011
    Link to this post
    I had a structure like this:

    Pagegroup named AtLAS at the root
    Pagegroup 2011 inside AtLAS.
    Pagegroups 9 and 12 inside 2011.
    Pages attached to 9 and 12.

    After dragging 2011 to the root of the site, I had two pagegroups at the root, AtLAS and 2011.
    If I go to my pages which have links on them, created with the Sitefinity RadEditor, the paths are not re-calculated... they still contain "atlas/".
    I noticed that my 2011 folder then had a checkbox checked for alternate URLs for this page, which contained a path with "atlas/" which no longer exists, so I unchecked the box, but my links are still busted.
    I definitely don't remember this behavior in Sitefinity 3.7. Is this a new "feature" of 4.x?
    I've also noticed that if I add an image to an album and then rename that image, it automatically creates alternate URLs which display that image. This should not be turned on by default! 
    I had an album with slide01.jpg, slide02.jpg, slide03.jpg. I then created a widget which sorts by title to order my slideshow. If I rename slide03.jpg to slide04.jpg and upload a new slide03.jpg, I end up with the tthumbnails of the original slide03 showing for both slide03 and slide04 in the backend and no thumbnail showing the new slide03!
    Is there a global way to disable this behavior of creating redirects on everything that is renamed! Once a site goes live, I could see wanting to support users who have bookmarked things, but while building the site, it is driving me crazy.

    As usual an suggestions for dealing with this will be appreciated.
  2. Miroslava
    Miroslava avatar
    57 posts
    Registered:
    16 Jan 2017
    13 Dec 2011
    Link to this post
    Hello Scott Rozman,

    Thank you for contacting Telerik support team. I logged a PITS issue regarding the problem that you experience. Its ID is 8871. You can follow it using this URL and vote for it:
    http://www.telerik.com/support/pits.aspx#/public/sitefinity/8871
    There isn't a way to globally disable creating of additional URL in 4.3. As for images, you can try to unpublish your images, make changes while building your site and publish them before going live. Making changes in unpublished images will not add additional URLs. As for the URLs to pages from your project that are not recalculated, this is an expected behaviour and these URLs that are already created with RadEditor should be changed manually.

    Kind regards,
    Miroslava
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
3 posts, 0 answered