1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Cannot access a page after upgrading to 4.2 (Specified argument was out of the range of valid values. Parameter name: index)

Cannot access a page after upgrading to 4.2 (Specified argument was out of the range of valid values. Parameter name: index)

8 posts, 1 answered
  1. Jamie
    Jamie avatar
    14 posts
    Registered:
    25 Mar 2011
    30 Aug 2011
    Link to this post
    Hi there,

    After Upgrading my website to 4.2 I have been having an issue with my homepage. I can view it in the browser no problem, and even edit the page while browsing the site. But when I try to go into edit the content directly from sitefinity I get the following error:

    Specified argument was out of the range of valid values.
    Parameter name: index


    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.ArgumentOutOfRangeException: Specified argument was out of the range of valid values.
    Parameter name: index

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [ArgumentOutOfRangeException: Specified argument was out of the range of valid values.
    Parameter name: index]
       System.Web.UI.ControlCollection.get_Item(Int32 index) +8750274
       System.Web.UI.ControlCollection.RemoveAt(Int32 index) +31
       Telerik.Sitefinity.Web.UI.ZoneEditor.ProcessMisplacedControls() +913
       Telerik.Sitefinity.Web.UI.ZoneEditor.CreateChildControls() +104
       System.Web.UI.Control.EnsureChildControls() +102
       System.Web.UI.Control.PreRenderRecursiveInternal() +42
       System.Web.UI.Control.PreRenderRecursiveInternal() +175
       System.Web.UI.Control.PreRenderRecursiveInternal() +175
       System.Web.UI.Control.PreRenderRecursiveInternal() +175
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2496
    

    I cannot see what is causing the issue. Other pages with the same/similar controls are working properly.

    Has anyone seen this before? if so , was you able to resolve it?

    Thanks,
    Jamie
  2. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    01 Sep 2011
    Link to this post
    Hello Jamie,

    This is strange indeed. I suppose something went wrong during the upgrade. One solution is to send us your database and configuration files so we could reproduce the issue locally.

    Otherwise you could try deleting and recreating the home page if it is the only page that is causing problems.

    Kind regards,
    Lubomir Velkov
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

    Answered
  3. Armen
    Armen avatar
    11 posts
    Registered:
    07 Feb 2008
    25 Oct 2011
    Link to this post
    Hello Lubomir,

    I had this issue several times now. The recreating the page is fixing the issue but this is not good experience for the end user managing the site. Can you please let me know if there are specific sections I can check to fix when having such a problems? As it will not be convenient to send a DB backup each time when pages are bringing "Specified argument was out of the range of valid values".

    Thanks,
    Armen


  4. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    27 Oct 2011
    Link to this post
    Hi Armen,

    Unfortunately I don't see how we can find a solution for this problem if we do not have the database and the configuration files locally, so we could reproduce the environment and see what is wrong. You can check your upgrade log to see if there weren't any errors during the upgrade process. Also check if your modules have the same version in SystemConfig.config - if they don't that means that some of them weren't upgraded properly.

    Greetings,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Armen
    Armen avatar
    9 posts
    Registered:
    26 Oct 2011
    09 Nov 2011
    Link to this post
    Hi Lubomir,

    This is starting to repeat for us, not sure why. May be that is because we are using NLB? Not sure.

    Basically deleting and recreating the page is solving the issue but it is starting to happen again on some page. I would delete it and create once again but I have another problem coming after that. Some other pages have links to that page, and I am interested when deleting some page, can I know which pages have link to that page that I delete so that after I can go and try to fix those links.
    We have more than 500 pages and it is hard to go over all pages to verify broken links and reason after.

    Thanks,
    Armen
  6. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    10 Nov 2011
    Link to this post
    Hi Armen,

    When you delete a page with additional URLs these additional URLs are deleted as well. So you can recreate the page with the same additional URLs the links to this page should be good. Unfortunately
    there is no way to detect broken links, as you can have custom or user controls, whose content we cannot examine.

    Best wishes,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Armen
    Armen avatar
    9 posts
    Registered:
    26 Oct 2011
    10 Nov 2011
    Link to this post
    Hi Lubomir,

    Thank you for your answer.

    I agree with URLs but it also contains sfref="[pages]fcca4b4a-722a-4daa-a0c5-c081829aefca" parameter. Which I believe will be not valid after that. Can we just ignore that?

    Regarding links I was mostly interested within your native content, not the custom controls built by us. Like if we are deleting some page it will be very helpful to know which pages will have broken links.

    Thanks,
    Armen
  8. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    14 Nov 2011
    Link to this post
    Hi Armen,

    Yes, the sfref attributes point to page GUIDs that will be different after you delete and recreate the page. Basically our parser would check the GUID and generate a proper link to the page, if the GUID exists. Otherwise there would be no link.

    Unfortunately we do not have an out of the box tool, or even API methods, that would verify the content of News items, Generic contents, etc. for broken links.

    All the best,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
8 posts, 1 answered