Try Now
More in this section

Forums / Bugs & Issues / Failed to create a 'Settings' from the text 'Assembly references and imported namespaces serialized as XML namespaces'.

Failed to create a 'Settings' from the text 'Assembly references and imported namespaces serialized as XML namespaces'.

5 posts, 0 answered
  1. Devin
    Devin avatar
    149 posts
    09 Jun 2009
    08 Apr 2011
    Link to this post
    We got this error message in a popup window when accessing some back-end pages, such as Amdin -> Pages.
    Now we cannot do modifications on our page contents.

    Does anyone found similar errors before?

    Please help.
  2. Victor Velev
    Victor Velev avatar
    1345 posts
    06 Jul 2015
    10 Apr 2011
    Link to this post
    Hi Devin,

    Can you give me more details about your project - is it new or upgraded? Have you done any customizations (controls, widgets) ? Also can you use Firebug and check what error is coming up? Can you tell me what actions have you taken prior to the error? Have you tried to reproduce it in a blank new project ( if your current one has been modified ).

    Victor Velev
    the Telerik team

  3. Matthew
    Matthew avatar
    6 posts
    20 Jul 2011
    20 Dec 2012
    Link to this post

    For those who've searched for this error and need a solution (as I did):

    I was also receiving the same error in the same circumstances. The actual error was

    Could not load file or assembly 'Telerik.OpenAccess, Version=2012.3.1012.1, Culture=neutral, PublicKeyToken=7ce17eeaf1d59342' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

    This was Sitefinity 5.1.3450.0 and Telerik.OpenaAccess 2012.2.628.2. I didn't have time to figure out why this was happening, I just added an Assembly Binding to web.config to resolve this:

        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
            <assemblyIdentity name="Telerik.OpenAccess" publicKeyToken="7ce17eeaf1d59342" culture="neutral"/>
            <bindingRedirect oldVersion="2012.3.1012.1" newVersion="2012.2.628.2"/>

  4. Tys
    Tys avatar
    21 posts
    21 Jul 2011
    10 Apr 2013
    Link to this post
    Just to let you know, i got this error when i configured log4net in my Sitefinity project but i forgot to include the log4net.dll in my project bin. After copying the file the problem was gone. 
  5. Liviu
    Liviu avatar
    13 posts
    15 Feb 2012
    04 Dec 2013
    Link to this post
    A .dll problem here too.
    I did not know that until took a look in error.log file (App_Data\Sitefinity\Logs\Error.log) where i found 
    Inner Exception
    Type : System.IO.FileNotFoundException, mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089
    Message : Could not load file or assembly 'vjscor, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

    After including   <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <probing privatePath="bin;bin\HttpModules;bin\Providers;bin\Modules;bin\Support;"/>
            <assemblyIdentity name="vjscor" publicKeyToken="b03f5f7f11d50a3a"/>
            <bindingRedirect oldVersion="" newVersion=""/>

    in web.config, everything is fine now.

5 posts, 0 answered