Try Now
More in this section

Forums / Bugs & Issues / Getting 'Object Reference not set' error when editing pages - old version!

Getting 'Object Reference not set' error when editing pages - old version!

2 posts, 0 answered
  1. aaron
    aaron avatar
    2 posts
    23 Sep 2008
    05 Aug 2013
    Link to this post
    We're running Sitefinity 3.7 on one of our sites.
    I don't know what's recently changed apart from content in pages, I've been reassured nothing structural, but all of a sudden whenever we try to edit a page in the admin, we get an error "Object reference not set to an instance of an object."
    The front-end still looks fine, and the back-end navigates fine, we just can't edit anything.
    I don't know where to look in SF for more info or details.

    Any clues?

    (I know this is a very old version, but it's been working fine for a long time and "just upgrade it" is not really an option to fix a spontaneous issue.)
  2. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    28 Oct 2016
    08 Aug 2013
    Link to this post

    If all controls placed in the backend page return object reference then the .NET framework version has been changed either on the server were the site runs or the application pool uses different .net version now. Refer to this KB article to check the current version of 3.7 site and then see what .net version have to be used for the application pool running the site if there have been changes.

    Stanislav Velikov
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered