+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / gif image upload quality problem [4.3.1873]

gif image upload quality problem [4.3.1873]

9 posts, 1 answered
  1. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    05 Nov 2011
    Link to this post
    Hey,

    Not that I use .gif really but I've got this standard 'anonymous profile' picture (79x79) which I tried uploading in Sitefinity just to play around with images a bit but the image gets totally distorted after upload.

    In the first screenshot (overview) you see on the left how it looks in Sitefinity and on the right how it looks when the image is opened directly in IE and MS Picture Manager (zoom 300%). In the second screenshot, you'll see the uploaded image more clearly in the Sitefinity Image Editor.

    Is there a setting somewhere hidden where you need to set how .gif's are uploaded? Or is this not Sitefinity related but an issue with the new image uploader/editor? Because I verified it with a v4.2.1733 and the image is uploaded correctly in that instance...

    I've tried both uploading the image from the image widget aswell as from the RadEditor, but on both occasions it gets warped. The original image is included as the last attachment.

    Jochem.
  2. Keivan Kechmiri
    Keivan Kechmiri avatar
    38 posts
    Registered:
    16 Aug 2009
    07 Nov 2011
    Link to this post
    I'm having the exact same problem, this worked fine in earlier versions on Sitefinity.

    The problem is that it is not only gif's that get modified when uploading images I've seen this on jpg also (the change isn't that noticable, but the are modified and if you compare the size from the original it differs.

    This is a big problem for me.

    /Keivan
  3. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    06 Dec 2016
    09 Nov 2011
    Link to this post
    Hi Keivan,

    This is a bug introduced with Sitefinity 4.3. We will provide a fix for the next release. Please excuse us for the inconvenience.

    Best wishes,
    Stanislav Velikov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
  4. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    09 Nov 2011
    Link to this post
    Dear Stanislav

    How bad is this bug. (have not had a chance to test 4.3)

    Is this effecting really all images. How bad is it and should we wait to update our 4.2 versions to 4.3

    And if you are writing next release is this 4.3 Hotfix 1 or do we have to wait for 4.4?

    Markus
  5. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    11 Nov 2011
    Link to this post
    Apparantly the 'next' release is a hotfix, where this issue is fixed.... More details after the link.
  6. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    11 Nov 2011
    Link to this post
    @Telerik

    Thanks for the quick fix. All I need now are 4.3 language files and I will be able to update to 4.3 as well.

    @Jochem

    Thanks for reporting it.

    Markus
  7. Rory
    Rory avatar
    44 posts
    Registered:
    22 Mar 2012
    22 Mar 2012
    Link to this post
    Hello all.  i am using Sitefinity 5 (5.025.00) and am having this problem with .gif images.  the image is the same size but the image quality is being very noticeably reduced while the file size is being increased slightly.  Jpg's and Png's seem to work fine.  Not a huge problem just a little annoying.
  8. Rory
    Rory avatar
    44 posts
    Registered:
    22 Mar 2012
    22 Mar 2012
    Link to this post
    double post
  9. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    22 Mar 2012
    Link to this post
    Hey Rory,

    Quote unquote from another thread but it still applies to this:
    "With regards to your issue:
    Yes this bug was introduced with SF v4.3, and there was a hotfix for it, that part has been fixed. However, there are still two (unrelated) image quality issue floating around, which were not fixed in Sitefinity v4.4 (also mentioned under the known issues).
     
    One of these will only be introduced if you manually added a RadCompression line to your web.config to even further compress the your data calls, so that's probably not the case.
     
    There has been no fix introduced for these in SF v4.4. PITS shows the progress currently as open, but that's not always a good indicator, so shortly before a new release."

    The PITS issue mentioned there is unfortunately still open with v5.0... 

    Jochem
9 posts, 1 answered