Try Now
More in this section

Forums / Bugs & Issues / Image gallery not loaded in news item detail page

Image gallery not loaded in news item detail page

2 posts, 0 answered
  1. Paulo
    Paulo avatar
    21 posts
    06 Dec 2010
    23 Jan 2014
    Link to this post

    I'm using the sitefinity  6.2.4910 version,  and when I insert an image gallery widget in the page that is used to show the news details, the gallery does not  load any images.  

    To produce this issue do the next steps:

    -  create a new page for the news details
    - add a news widget to the page
    - add a  image gallery  widget to the page and configure it to show  all items of one of your galleries in simple list mode 

     - create a page for the news list 
     - add a news widget  
     - configure the news widget and set the single item settings to use your created details page

    You will see that wen you click the news to view  the details, the image gallery will not show any images, but if you navigate to  the page without the news parameters those images appears correctly
  2. Ivan D. Dimitrov
    Ivan D. Dimitrov avatar
    310 posts
    26 Mar 2015
    28 Jan 2014
    Link to this post
    Hi Paulo,

    The reason you are experiencing this behavior is because of the UrlEvaluationMode of the news widget placed on the details page. In order for you to be able to see both the image gallery and the news details view, you need to edit the widget by clicking Edit->Advanced and change the UrlEvaluationMode to QueryString. This needs to be done on the details widget i.e. on the pageAt this point you will not observe the behavior the gallery widget.  

    Ivan D. Dimitrov
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered