+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Invalid resource

Invalid resource

12 posts, 0 answered
  1. Andreas
    Andreas avatar
    7 posts
    Registered:
    06 Aug 2012
    06 Aug 2012
    Link to this post
    Hello.

    Can someone share a solution for this?

    Klicking the link results in an error:

    404 - File or directory not found.

  2. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    06 Aug 2012
    Link to this post
    Hi Andreas,

    The problem comes from the fact that the license that you have used for the project does not have the mobile add - on included, so that the resources are not loaded. In order to resolve the issue you can go to the backend pages section of the site and delete the page ( and its child page ):

    Responsive & Mobile design
    ( which is located under the Design node ). Then restart the application and you will not be seeing the error message about the missing resources.

    Regards,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Andreas
    Andreas avatar
    7 posts
    Registered:
    06 Aug 2012
    09 Aug 2012
    Link to this post
    Thank you for the fast response.
  4. Andreas
    Andreas avatar
    7 posts
    Registered:
    06 Aug 2012
    09 Aug 2012
    Link to this post
    Unfortunately following your tips i get this error after clicking Ok, Continue.
    Clicking OK on the error message gives me a blank white main with "Loading" in the upper left.
  5. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    09 Aug 2012
    Link to this post
    Hi Andreas,

    We have KB article regarding the error you are getting when accessing the backend pages:

    http://www.sitefinity.com/devnet/kb/sitefinity-5-x/when-accessing-the-backend-pages-of-sitefinity-you-are-getting-invalid-uri-the-uri-scheme-is-not-valid.aspx


    Greetings,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Andreas
    Andreas avatar
    7 posts
    Registered:
    06 Aug 2012
    23 Aug 2012
    Link to this post
    Followed the KB article and we are still having the same issues when returning to the standard license.
    Klicking the Tab Administation > Permission gives this error, over and over again:
    Could not find the specified key "AccessResponsiveDesign" or class id "ResponsiveDesignResources"
  7. Micke Palm
    Micke Palm avatar
    17 posts
    Registered:
    27 Aug 2012
    27 Aug 2012
    Link to this post
    Hi there,

    Any good result of this thread? I followed the KB and solved the menu problem ,but I got some problem under permission. This should be solved with an path or can we upgrade to 5.1 and the problem is gone?

    /Thanks
  8. Atanas Valchev
    Atanas Valchev avatar
    414 posts
    Registered:
    04 Jan 2016
    27 Aug 2012
    Link to this post
    Hello,

     You can comment out the following section in the Securityconfig.config file and it should get rid of the error when accessing the permissions section:

    <permissions>
        <permissionname="Backend">
            <actions>
                <!--<add title="AccessResponsiveDesign" description="AccessResponsiveDesignDescription" resourceClassId="ResponsiveDesignResources" type="None" name="AccessResponsiveDesign" />-->
                <addtitle="AccessForums"description="AccessForumsDescription"resourceClassId="ForumsResources"type="None"name="AccessForums"/>
            </actions>
        </permission>


    All the best,
    Atanas Valchev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  9. Micke Palm
    Micke Palm avatar
    17 posts
    Registered:
    27 Aug 2012
    27 Aug 2012
    Link to this post
    Thanks Atanas! That solved the problem :)

    How come with an upgrade to 5.1. Can that solved the problem too or is the issue still there?

    /Thanks
  10. Wilko
    Wilko avatar
    6 posts
    Registered:
    30 Aug 2013
    17 Mar 2014
    Link to this post

    Hi, I'm using Sitefinity 6.2.4910.0  and we are having the issue when we want to change the permissions for a role:

    #ResourceNotFound#:ResponsiveDesignResources:AccessResponsiveDesign

    But when I take a look in Securityconfig.config I do not see the "Backend" permission. I do see some permission sections like forum and forum group but not the Backend. Are these permission settings stored elsewhere in Sitefinity 6.2.4910.0? 

    How can I solve this problem?

  11. Atanas Valchev
    Atanas Valchev avatar
    414 posts
    Registered:
    04 Jan 2016
    20 Mar 2014
    Link to this post
    Hello,

    For your version, please, go to Administration - Modules and Services and first disable and then uninstall the responsive design module. After that install it again and the issue should be resolved.

    Regards,
    Atanas Valchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  12. Wilko
    Wilko avatar
    6 posts
    Registered:
    30 Aug 2013
    24 Mar 2014
    Link to this post

    That worked out fine!! thanks

12 posts, 0 answered