Try Now
More in this section

Forums / Bugs & Issues / Issue disabling cmsentrypoint.aspx

Issue disabling cmsentrypoint.aspx

3 posts, 0 answered
  1. Adam
    Adam avatar
    2 posts
    13 May 2011
    18 May 2011
    Link to this post

    We have an application running on sitefinity cms and all is well .  However beneath this application we have another application that has nothing to do with sitefinity at all.  For some reason when we go to this application using the http://servername/subapplication/ url we get a 404 error: Requested URL: /subapplication/sitefinity/cmsentrypoint.aspx

    I feel like I've basically tried everything to get sitefinity to not affect this application that is sitting beneath it.  Any input is much appreciated. 
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    12 Sep 2017
    18 May 2011
    Link to this post
    Hi Adam,

    It seems that configuration you use force calling an internal handler before page internal check and you are redirected to our cmsentrypoint.aspx.  Please add all modules/handlers after CmsHttpModule. All page requests pass through cmsentrypoint.aspx. The file inherits InternalPage.cs which implements methods for page management- getting  the mode of the page, name of the ICms Page, instance of CmsManager, optional page settings like EnableViewState, returns the name of the Theme to be set for the current page . Our CmsHttpModule rewrites the URL to cmsentrypoint.aspx, which is the page handler for each CMS page in the Sitefinity. It seems that something in your project forces calling an internal handler before page internal check and you are redirected to our cmsentrypoint.aspx. This could also happen if you force some custom logic for logging users.

    Also make sure that there is no web.config inheritance


    which is quite common in asp.net nested application.

    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Adam
    Adam avatar
    2 posts
    13 May 2011
    18 May 2011
    Link to this post
    Thank you very much for your assistance,

    After a good night sleep I came in and retried everything.  I had already disabled inheritance but in the child php application in the web.config file I needed to add under <system.webserver>

        <validation validateIntegratedModeConfiguration="false" />
                <remove name="ScriptModule" />
                <remove name="Cms" />
                <remove name="UrlRoutingModule" />
                <remove name="RadUploadModule" />
                <remove name="UrlRoutingHandler" />
                <remove name="ScriptResource" />
                <remove name="WebServiceHandlerFactory-Integrated" />
                <remove name="ScriptHandlerFactory" />
                <remove name="ScriptHandlerFactoryAppServices" />
                <remove name="SitefinityTemplate" />
                <remove name="SitefinityThumbnail" />
                <remove name="SitefinityLibrary" />
                <remove name="RadUploadProgress" />
                <remove name="SitefinityRSS" />
                <remove name="Dialog" />
                <remove name="Spellcheck" />
                <remove name="ChartImage" />
                <remove name="CaptchaImage" />
                <remove name="Metablog" />
                <remove name="Trackback" />
                <remove name="AmazonLibrary" />
                <remove name="AmazonLibraryAdd" />
                <remove name="SitefinityThumbnailAdd" />
                <remove name="SitefinityRSSAdd" />
                <remove name="SitefinityLibraryAdd" />

    Probably don't need all of this but it worked!  Thanks so much!

3 posts, 0 answered