+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Login / Logout Button Error

Login / Logout Button Error

5 posts, 0 answered
  1. Robert
    Robert avatar
    26 posts
    Registered:
    19 Mar 2011
    15 Mar 2014
    Link to this post

    Hi,

     I'm experiencing an error in Sitefinity whenever I load a page that contains the "Login/Logout Button" and the user is logged out.

     If the user is logged in or a page doesn't contain the "Login / Logout Button" widge, then the error is not experienced.

    The login/logout button widget is placed in the page via the "Page Templates" section of Sitefinity.

     My version of Sitefinity is 6.3.5.

     The error is as follows:

    Server Error in '/' Application.Post cache substitution is not compatible with modules in the IIS integrated pipeline that modify the response buffers.  Either a native module in the pipeline has modified an HTTP_DATA_CHUNK structure associated with a managed post cache substitution callback, or a managed filter has modified the response.Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

    Exception Details: System.InvalidOperationException: Post cache substitution is not compatible with modules in the IIS integrated pipeline that modify the response buffers.  Either a native module in the pipeline has modified an HTTP_DATA_CHUNK structure associated with a managed post cache substitution callback, or a managed filter has modified the response.

    Source Error: 

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
    Stack Trace: 

    [InvalidOperationException: Post cache substitution is not compatible with modules in the IIS integrated pipeline that modify the response buffers. Either a native module in the pipeline has modified an HTTP_DATA_CHUNK structure associated with a managed post cache substitution callback, or a managed filter has modified the response.]
    System.Web.HttpWriter.GetIntegratedSnapshot(Boolean& hasSubstBlocks, IIS7WorkerRequest wr) +3072146
    System.Web.HttpResponse.GetSnapshot() +122
    System.Web.Caching.OutputCacheModule.OnLeave(Object source, EventArgs eventArgs) +936
    System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +136
    System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +69

    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.34009

     

    Any advice would be greatly appreciated. Many thanks.

  2. Robert
    Robert avatar
    26 posts
    Registered:
    19 Mar 2011
    15 Mar 2014
    Link to this post

    Could the problem be that I'm using VS2013?

  3. Vassil Vassilev
     Vassil Vassilev avatar
    308 posts
    Registered:
    21 Jan 2015
    19 Mar 2014
    Link to this post
    Hello Robert,

    Regarding your issue - Visual Studio 2013 is not officially supported. Thus I would recommend you not to use the IIS Express but set the project on IIS by following that article.

    Please let me know if the proposed solution helps.

    Regards,

    Vassil Vassilev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  4. Robert
    Robert avatar
    26 posts
    Registered:
    19 Mar 2011
    22 Mar 2014 in reply to Vassil Vassilev
    Link to this post

    Yea, it's because I was using VS2013.

     I tried it in VS2010 after upgrading VS2010 to MVC4 (update can be download from microsoft here) and it now works perfectly.

     Thank you for getting back to me.

     Rob

  5. Vassil Vassilev
     Vassil Vassilev avatar
    308 posts
    Registered:
    21 Jan 2015
    24 Mar 2014
    Link to this post
    Hello Robert,

    I am glad I you were able to fix this problem. Note also you can use also VS 2012.

    Do not hesitate to open a support ticket if any other issue occur, we will be happy to assist you.

    Kind regards,
    Vassil Vassilev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
5 posts, 0 answered